• libksysguard package fails update, damaged / cannot load metadata


    I have problems with package libksysguard-5.14.3-1 as it fails to update. Have tried
    this but with no success. Have also updated the package database. What else could I try?

  • Have you tried to change the mirror?

  • Try verification,sudo pacman -Dk and sudo pacman -Qk see https://wiki.archlinux.org/index.php/Pacman/Rosetta#Verification_and_repair

  • I do not yet know how to change the mirror, however, the -Dk tells me
    Fehler: ‘libksysguard-5.14.3-1’: description file is missing
    Fehler: ‘libksysguard-5.14.3-1’: file list is missing
    so I guess this is the hint.

    I tried to reinstall with pacman -S but it won’t work.

    it say it cannot find /var/lib/pacman/local/libksysguard-5.14.3-1/desc

    //

    I have removed libksysguard and plasma-workspace and now the update procedure worked. I do not know what I need these packages for anyway.

  • Which DE are you using, because the two packages you’ve removed are quite essential for KDE.

  • just gnome

  • Okay, then just check, to make sure, if all your apps are working correctly. You might have installed a KDE app that depends on those packages. If not it was problably installed with an app you’ve already removed.

  • @Popkultur The last time I had an issue like this I did rm -rf /var/lib/pacman/local/xxxx and then reinstalled. This was based on a solution I found for some other issue.
    It’s probably worth seeing is you still have /var/lib/pacman/local/libksysguard* and removing, to avoid problems in the future.

fails37 damaged2 libksysguard1 Posts 8Views 95
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.