• error: resume: no device specified for hibernation systemd


    Hello everyone!
    I’ve just installed Antergos, but I’ve got a problem with systemd.
    When i try to boot it, appears the message: “error: resume: no device specified for hibernation”.
    I can boot normally, but I got this error.
    Is there any solution?
    I’ve got a laptop with 1TB HDD disc, I7-6700HQ CPU, Nvidia GTX 950 GPU, 8gb RAM.

  • @manuel
    The problem is that I’ve got systemd and not GRUB2, so I’ve not got that file…

  • @Pablo231200
    Oh sorry, didn’t notice systemd… The solution probably is something similar but unfortunately I don’t know about systemd boot. Maybe @joekamprad knows?

    Also the Arch pages could have a solution.
    Anyway, the message is not dangerous…

  • @manuel
    Don’t worry, you 're so gentile, so many thanks.
    I’m trying to search in the Arch pages, but I don’t understand what to do :)
    Sure, the message isn’t dangerous, but I prefer to “repair” it.
    Anyone more who could help me, please?

  • never use systemdboot here… but there is the same “resume=” kernel parameter used at systemdboot… it has config file somewhere here:

    /boot/loader/entries/
    

    https://wiki.archlinux.org/index.php/Kernel_parameters#systemd-boot

  • I’ve seen both messages.
    @joekamprad Inside /boot/loader/entries I’ve got antergos.conf
    @manuel I’ve seen that webpage, but it doesn’t clarify me anything… Because I’ve never used Arch before, and I don’t understand it so well…
    Sorry.

  • @Pablo231200 said in error: resume: no device specified for hibernation systemd:

    /boot/loader/entries I’ve got antergos.conf

    show us:

    cat /boot/loader/entries/antergos.conf
    
  • I’ve seen this post:
    https://forum.antergos.com/topic/7849/issues-with-hibernation/3
    But I don’t understand what @illusiveman do.
    May someone explain me the steps, please?
    Thank you very much.

  • if you do not have encrypted LM it would be wrong to follow what @illusiveman was doing ;)

    to help you i need to see what is inside antergos.conf file… then i can guide you

  • @joekamprad

    title	Antergos
    linux	/vmlinuz-linux
    initrd	/intel-ucode.img
    initrd	/initramfs-linux.img
    options	root=UUID=059a79d4-8de0-4d68-b8bf-685924219d67 rw quiet
    
  • @Pablo231200 as you can see file missing resume option…

    resume=UUID=

    title	Antergos
    linux	/vmlinuz-linux
    initrd	/intel-ucode.img
    initrd	/initramfs-linux.img
    options	root=UUID=059a79d4-8de0-4d68-b8bf-685924219d67 resume=UUID=*swap-uuid-here* rw quiet
    
    lsblk -f | grep swap
    

    will give it to you…

    sudo nano /boot/loader/entries/antergos.conf
    

    add resume=UUID=*swap-uuid-here* ((replace *swap-uuid-here* with the uuid of your swap device)) ,save the file [Ctrl+X] and rebuild systemd-boot:

    Manual update
    bootctl must be used to update systemd-boot. If the path parameter is not specified, /efi, /boot, and /boot/efi are checked in turn.

    sudo bootctl update

  • @Pablo231200
    If you don’t want to use hibernation, you may remove the resume word from the HOOKS variable in file /etc/mkinitcpio.conf. Then you need to create initramfs, and that is easy to do simply by reinstalling kernel(s) you are using, for example:

    sudo pacman -S linux
    sudo pacman -S linux-lts
    

    This will also take away the error message at boot.

    But if you do want to use hibernation, then as Joe explained above, you need to have a swap partition (or swap file) and specify the resume property to refer to the swap partition.

  • Solved!
    Thank you very much @joekamprad and thank you @manuel too!
    I’ve repaired it, and now I can hibernate.

  • @Pablo231200 you are welcome.

error311 device27 resume5 specified3 Posts 16Views 79
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.