• new install GNOME `systemctl status --user` not working

    hi guys I installed yesterday the new Antergos 18.11 and everything was working except when i tried to install a user service:
    systemctl status --user
    Failed to connect to bus: No such file or directory

    when i tried this command on terminal env i got:
    XDG_MENU_PREFIX=gnome- LANG=en_US.UTF-8 GDM_LANG=en_US.UTF-8 DISPLAY=:0 QT_STYLE_OVERRIDE=gtk EDITOR=/usr/bin/nano COLORTERM=truecolor USERNAME=linux XDG_VTNR=2 QT_SELECT=qt5 SSH_AUTH_SOCK=/run/user/1000/keyring/ssh XDG_SESSION_ID=2 USER=linux DESKTOP_SESSION=gnome-xorg LC_COLLATE=en_US.UTF-8 GNOME_TERMINAL_SCREEN=/org/gnome/Terminal/screen/d7fe41ee_4776_427f_8ac7_a4981da9e1cd PWD=/home/linux HOME=/home/linux BROWSER=/usr/bin/chromium XDG_SESSION_TYPE=x11 XDG_SESSION_DESKTOP=gnome-xorg GJS_DEBUG_OUTPUT=stderr MAIL=/var/spool/mail/linux WINDOWPATH=2 TERM=xterm-256color SHELL=/bin/bash VTE_VERSION=5402 XDG_CURRENT_DESKTOP=GNOME GNOME_TERMINAL_SERVICE=:1.56 XDG_SEAT=seat0 SHLVL=1 GDMSESSION=gnome-xorg LOGNAME=linux DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus XDG_RUNTIME_DIR=/run/user/1000 XAUTHORITY=/run/user/1000/gdm/Xauthority PATH=/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl GJS_DEBUG_TOPICS=JS ERROR;JS LOG SESSION_MANAGER=local/linux:@/tmp/.ICE-unix/549,unix/linux:/tmp/.ICE-unix/549 _=/usr/bin/env
    also on this command: export -p | grep XDG
    the output was:
    declare -x XDG_MENU_PREFIX="gnome-"
    declare -x XDG_RUNTIME_DIR="/run/user/1000"
    declare -x XDG_SEAT="seat0"
    declare -x XDG_SESSION_DESKTOP="gnome-xorg"
    declare -x XDG_SESSION_ID="2"
    declare -x XDG_SESSION_TYPE="x11"
    declare -x XDG_VTNR="2"

    lastly on some search they said that i should
    export XDG_RUNTIME_DIR=/run/user/'id -u'
    and the i should sudo systemctl restart systemd-logind.service
    but it didnt help either…

    can anyone help??

  • @qaron said in new install GNOME `systemctl status --user` not working:

    systemctl status --user
    Failed to connect to bus: No such file or directory

    you try to status user service as root ?

    it must be done as normal user…

  • @joekamprad
    no i want to create a user service and i cant deploy it
    for example:

    ExecStart=/usr/bin/xscreensaver -no-splash

    and then run :

    [[email protected] ~]$ systemctl start --user xscreensaver.service
    Failed to connect to bus: No such file or directory

    thats what i want to do

  • @joekamprad

    before format i did the above and it worked:

    [[email protected] ~]$ systemctl status --user xscreensaver.service
    ● xscreensaver.service - XScreenSaver
       Loaded: loaded (/home/linux/.config/systemd/user/xscreensaver.service; enabled; vendor preset: enabled)
       Active: active (running) since Tue 2018-12-04 15:47:26 EET; 2h 28min ago
     Main PID: 1094 (xscreensaver)
       CGroup: /user.slice/user-1000.slice/[email protected]/xscreensaver.service
               └─1094 /usr/bin/xscreensaver -no-splash
    Δεκ 04 15:47:26 linux systemd[660]: Started XScreenSaver.

    and by the way the previous command should give output:

    [[email protected] ~]$ systemctl status --user
    ● linux
        State: running
         Jobs: 0 queued
       Failed: 0 units
        Since: Tue 2018-12-04 15:47:20 EET; 2h 30min ago
       CGroup: /user.slice/user-1000.slice/[email protected]
               │ └─927 /usr/lib/gvfs-goa-volume-monitor
               │ └─807 /usr/lib/xdg-permission-store
               │ └─1036 /usr/lib/tracker-store
               │ └─1127 /usr/lib/evolution-calendar-factory
               │ ├─790 /usr/bin/pulseaudio --daemonize=no
               │ └─797 /usr/lib/pulse/gsettings-helper
               │ ├─  743 /usr/lib/gvfsd
               │ ├─  748 /usr/lib/gvfsd-fuse /run/user/1000/gvfs -f -o big_writes
               │ ├─ 1207 /usr/lib/gvfsd-trash --spawner :1.4 /org/gtk/gvfs/exec_spaw/0
               │ ├─ 4392 /usr/lib/gvfsd-network --spawner :1.4 /org/gtk/gvfs/exec_spaw/1
               │ ├─ 4405 /usr/lib/gvfsd-dnssd --spawner :1.4 /org/gtk/gvfs/exec_spaw/3
               │ ├─ 4531 /usr/lib/gvfsd-smb-browse --spawner :1.4 /org/gtk/gvfs/exec_spaw/4
               │ ├─ 4606 /usr/lib/gvfsd-smb --spawner :1.4 /org/gtk/gvfs/exec_spaw/5
               │ └─31731 /usr/lib/gvfsd-http --spawner :1.4 /org/gtk/gvfs/exec_spaw/6
               │ └─816 /usr/lib/evolution-source-registry
               │ └─848 /usr/lib/gvfs-udisks2-volume-monitor
               │ └─1094 /usr/bin/xscreensaver -no-splash
               │ ├─17729 /usr/lib/gnome-terminal-server
               │ ├─17736 bash
               │ ├─30585 systemctl status --user
               │ └─30586 less
               │ ├─660 /usr/lib/systemd/systemd --user
               │ └─661 (sd-pam)
               │ ├─760 /usr/lib/at-spi-bus-launcher
               │ ├─766 /usr/bin/dbus-daemon --config-file=/usr/share/defaults/at-spi2/accessibility.conf --nofork --print-address 3
               │ └─768 /usr/lib/at-spi2-registryd --use-gnome-session
               │ └─830 /usr/lib/gvfsd-metadata
               │ ├─ 728 /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation --syslog-only
               │ ├─ 812 /usr/lib/gnome-shell-calendar-server
               │ ├─ 823 /usr/lib/goa-daemon
               │ ├─ 826 /usr/lib/dconf-service
               │ ├─ 849 /usr/lib/telepathy/mission-control-5
               │ ├─ 876 /usr/lib/goa-identity-service
               │ └─1255 /usr/lib/gconfd-2
               │ └─1144 /usr/lib/evolution-addressbook-factory
               │ └─923 /usr/lib/gvfs-mtp-volume-monitor
                 └─931 /usr/lib/gvfs-afc-volume-monitor
    lines 3-60/60 (END)

    in other words shows all the user services that are running…

    but in yesterday installation it shows:

    [[email protected] ~]$ systemctl status --user
    Failed to connect to bus: No such file or directory
  • systemctl status --all dbus.socket


  • i can see the same her in a new VM install…

    only thing i can see is that standard user is not inside “users” group instead it is inside a group called like the username…

  • @qaron said in new install GNOME `systemctl status --user` not working:

    systemctl status --user

    do this asking you for password?

  • I’m having this exact same issue with a brand new i3 install.

    systemctl status --user does prompt for password.

  • I can see that this is not happening under a brandnew pure arch install…

    So must be something we do change on configuration? @developers @karasu @lots-0-logs ?

    Bild Text

  • can this be fixed someway now or should i wait for Antergos 18.12??

  • @qaron as i am not that firm on systemd, i involved devs to get what is wrong here…
    But must be solvable also on installed system.

  • I ran into the same problem today. Antergos alias systemctl="sudo systemctl" is the problem. Just unalias it and comment out that line in.bashrc.alias.

  • 🤦🏻♂
    alias … ;)
    but this one must be removed… as it makes no sence… beloved @developers ?

  • thank you!!! thank you!!! thank you!!! i worked!!!

  • @developers
    By default, aliases need to be kept at absolute minimum. I think aliases are the responsibility of each user, not really the devs that much… :)

    And I guess that alias was not meant to stay in the final ISO.

  • @manuel i think settings are not holded by ISO they come with antergos-desktop-settings ?

  • @joekamprad
    You’re right. The problem seems to be in file /etc/skel/.bashrc.aliases.

gnome361 status8 systemctl6 user6 Posts 17Views 478
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.