• GRUB failed to install on dual boot install with MacBook Pro (8,2)


    Installation was fine but grub failed. Booted back into the live system to check the boot partition, inside EFI folder there is antergos_grub, BOOT, and Microsoft. The last 2 has folders inside them but both are empty. Here’s how my partition scheme looks like:

    alt text

    How do I fix this? I also followed the guide Install dual boot MacOS X & Antergos on a MacBookPro 9,1 (Mid 2012) and even installed rEFInd but still doesn’t show up.

  • I was able to solve it by adding another ext4 partition mounted at /boot.

  • Just install Antergos with the following scheme:

    In your case wipe /devsdb4 till 6 with Gparted. Be very carefull and double check that you’re solely wiping those partitions, otherwise your entire drive will be wiped.
    Select the alocated space and:

    • Create a root partition (/) of 30/40 GB in ext4. This partition will be used for the system (/dev/sdb4)

    • Create a Swap partition (swap) 4 GB will be enough. (/dev/sdb5) There are debates about not having a swap partition, but some apps and system tools require a swap partition.

    • Create a Home partiton (/ home) with the rest of your disk space in ext4. (/dev/sdb6) This one will be used for your personal documents, video’s, music etc. To have this one separately is an advantage in case you have to reinstall the system, then your personal files won’t be effected.

    Then go to Cnchi and do the installation and when you get to the part of choosing the disk:

    • Choose for EFI (/boot/efi) /dev/sdb1

    • Choose for Root (/) /dev/sdb4

    • Choose for swap the swap partition

    Make sure that the partition boxes are all checked

    Choose /dev/sdb to install the bootloader.

    Now you’re good to go and after install Grub will list Antergos and Macos to boot from.

  • Then go to Cnchi and do the installation and when you get to the part of choosing the disk:

    • Choose for EFI (/boot/efi) /dev/sdb1
    • Choose for Root (/) /dev/sdb4
    • Choose for swap the swap partition

    I’ve tried this before creating another partition (/boot) and my MacBook still didn’t pick it up.

  • You don’t have to create a new boot partition, use the existing one. (The one that’s already installed with your Mac system.)

  • @cim
    I didn’t see your second post, problably caused by error in connecting to the forum.

  • @Bryanpwo I can now see the Antergos grub menu but booting stays black. I’ve entered these below set gfxpayload=keep:

    outb 0x728 1
    outb 0x710 2
    outb 0x740 2
    outb 0x750 0
    

    It’s still black.

  • Do you mean that it doesn’t boot at all?
    If so then boot the live iso and follow these instructions over here.

  • @Bryanpwo I’m able to type my password to unlock the partition after grub selection but then it just freezes at /dev/mapper/…: clean, [numbers] files, [numbers] blocks.

  • So you have to unlock the partition after the Grub menu or are you typing the password in the Antergos greeter? (this one has a random picture with a white login screen with the Antergos logo in it)
    If it’s the first, then it’s most likely te unusual partiton scheme you have going on.

  • @Bryanpwo second one with the greeter.

  • Than the problem is the AMD graphics card. You have to disable it to get to the intel graphics output.
    To do so read over here.

  • @Bryanpwo If I type out the outb stuff, the screen just completely blacks out. Adding radeon.modeset=0 i915.modeset=1 i915.lvds_channel_mode=2 does nothing, still freezes at /dev/mapper/…

  • Maybe the solution over here will help you out, just read the whole thread just for you to know what you’re about to going to do and in the last post the user sums up what worked out.

  • Hi

    This was working before on same MacBook Pro:

    On GRUB push direct ‘e’ then at the end of the ‘linux’ line put:

    api_osi=\"Linux\" nomodeset
    

    But just tested with the latest Antergos installer and screen is still black, cursor is visible (white) and chances while I hover over invisible (because screen is black) buttons.

    Tried to put the password in a invisible (because screen is black) field but I can’t manage. ;-)

    So system is proper installed, and loaded but all is black except the cursor. That’s a GPU, AMD problem, I think.

boot278 grub113 dual37 macbook25 Posts 15Views 97
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.