• Wayland and lightdm?


    I just tried installing KDE to play around with. It works well, but I also wanted to try a wayland session. When trying to launch it from lightdm I just get a black screen and then get thrown back to the login screen. I know lightdm has issues with wayland in the past, but that was years ago - can lightdm still not start wayland sessions?

  • Have you installed plasma-wayland-session? This is not installed by default on Antergos KDE and try it also with sddm.
    If those two don’t work either, it could be a hardware-Wayland compatibility problem.

  • Yes I have installed plasma-wayland-session, otherwise the wayland option would not show up in lightdm at all. But it seems it won’t launch. Yeah I guess I will have to try something other than lightdm (it was just a “for fun”-test so haven’t bothered yet - just curious what the cause is :) ).

  • IIRC sddm is recommended for KDE

lightdm135 wayland50 Posts 4Views 248
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.