• Antergos won't boot after manual partition install


    I have attempted this at least a dozen times to no avail. Fedora has been my main OS for ~6 months, but I’m pretty oblivious to the majority of command line / terminal stuff, though I try to learn. I certainly know NOTHING about Arch commands and was hoping to ease into it.

    I was able to create a live USB, and I found that the instructions for doing so on the Antergos wiki were pretty clear, and that I could correctly infer which blanks to fill in.

    Since the no-install issue with auto-partitioning seems completely out of my control, what can I do about the non-boot issue? I don’t know how I would get an error message or log from a system that doesn’t boot. Could someone advise me on how to do that?

    Edit: More info: I have been attempting to install Antergos onto an external hard drive. Fedora is still installed on my laptop (Thinkpad P50). This is the exact same thing I did when I switched from Windows to Fedora. I lived with it for a while before making the jump. You could see this as a dual-boot, but ‘dual-boot’ usually infers ‘Windows’, so I’m hesitant to call it that…

  • @Ge_Off
    Can you boot the machine with either Fedora or the USB installer stick? If so, then please do so and start the terminal (I know you may not like it…).
    Now, could you show us the output of the following commands:

    df -h
    

    About the logs in general, this may help: https://antergos.com/wiki/miscellaneous/how-do-i-include-system-logs-when-asking-for-help/

    If you cannot copy the output of the commands above here, then you could do something like this:

    df -h | curl -F [email protected] https://ptpb.pw/?u=1
    

    and copy the returned short net address here.

  • So if I understanfd you correctly: You have Fedora installed on your laptop and Antergos on an external harddrive. When the laptop starts up it only recognizes Fedora.
    Assuming your main host OS is still Fedora, the thing you have to do is to get the Grub bootloader (the screen you first see, before the Fedora screen) to recognize Antergos, so to try helping you out, you can follow the Fedora instructions over here.

  • @manuel

    I have no problem using the terminal to do things so long as I’m clear on what I’m doing and why. All too often there are vague descriptions that confuses noobs like myself.

    [***@localhost ~]$ df -h
    Filesystem                               Size  Used Avail Use% Mounted on
    devtmpfs                                 7.8G     0  7.8G   0% /dev
    tmpfs                                    7.8G   55M  7.7G   1% /dev/shm
    tmpfs                                    7.8G  1.4M  7.8G   1% /run
    tmpfs                                    7.8G     0  7.8G   0% /sys/fs/cgroup
    /dev/mapper/fedora_localhost--live-root   49G   12G   35G  26% /
    tmpfs                                    7.8G   90M  7.7G   2% /tmp
    /dev/sda2                                976M  198M  712M  22% /boot
    /dev/sda1                                200M   18M  183M   9% /boot/efi
    /dev/mapper/fedora_localhost--live-home  822G  100G  680G  13% /home
    tmpfs                                    1.6G   16K  1.6G   1% /run/user/1000
    /dev/sdb3                                 15G  6.1G  8.4G  43% /run/media/***/4305c339-541d-4c02-9299-c14474bdaf69
    /dev/sdb5                                275G   21M  273G   1% /run/media/***/5464ea20-e0c8-4cdb-9263-5fdfa678013e
    [***@localhost ~]$ ```
    code_text
    
  • @manuel Sdb is the external HDD I referenced earlier. Also, here’s what that drve looks like when I use fdisk -l:

    Disk /dev/sdb: 298.1 GiB, 320072933376 bytes, 625142448 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: gpt
    Disk identifier: A8E065A1-01FB-495D-AFF7-DEA3845560FC
    
    Device        Start       End   Sectors   Size Type
    /dev/sdb1      2048    411647    409600   200M EFI System
    /dev/sdb2    411648   2508799   2097152     1G EFI System
    /dev/sdb3   2508800  33758799  31250000  14.9G Linux filesystem
    /dev/sdb4  33758800  49383799  15625000   7.5G Linux filesystem
    /dev/sdb5  49383800 625142414 575758615 274.6G Linux filesystem
    

    code_text

  • @Ge_Off
    You have three EFI partitions (sda1, sdb1, sdb2), only one of them is needed.

    Could you show the output of command

    lsblk -fm
    

    I assume Fedora controls the booting (right?).
    Can you see Antergos on the boot menu? If not, recreate the boot menu in Fedora. Don’t remember how it is done, but in many systems it is:

    sudo update-grub
    

    Could you show the output of that command, too?

  • @Ge_Off
    Fedora handles EFI booting a bit different than Arch, so take your time to read the Fedora instructions.

  • @Bryanpwo Shouldn’t the bootloader be on the external HDD and not on the internal drive that my Fedora system resides on? This option comes up in Cnchi on both types of install and I always use the same device that all the other Antergos volumes are stored on.

  • @Ge_Off
    This may help: https://wiki.archlinux.org/index.php/GRUB#UEFI_systems
    as your system seems to be a UEFI system.

    In principal, you may put the grub stuff to any disk, but when booting, you need to have that drive connected. That’s why grub is normally put to an internal disk.

  • @manuel Sda is the drive that my Fedora system lives on. It is physically distinct from sdb, which is the drive I’m attempting to boot Antergos from.

    Here’s the result of lsblk -fm for the sdb drive:

    sdb                                                                 298.1G root  disk  brw-rw----
    ├─sdb1
    │    vfat         591C-7702                                           200M root  disk  brw-rw----
    ├─sdb2
    │    ext4         79e82fbe-7dcf-41fb-9a47-9cb8c1aeec15                  1G root  disk  brw-rw----
    ├─sdb3
    │    ext4         4305c339-541d-4c02-9299-c14474bdaf69   /run/media  14.9G root  disk  brw-rw----
    ├─sdb4
    │    swap         cf730706-1ed5-4cd2-ae6a-4db763efad7b                7.5G root  disk  brw-rw----
    └─sdb5
         btrfs        5464ea20-e0c8-4cdb-9263-5fdfa678013e   /run/media 274.6G root  disk  brw-rw----```
    

    And here’s what I get when I update grub:

    [[email protected] ***]#  grub2-mkconfig -o /boot/grub2/grub.cfg
    Generating grub configuration file ...
    Found linux image: /boot/vmlinuz-4.19.6-200.fc28.x86_64
    Found initrd image: /boot/initramfs-4.19.6-200.fc28.x86_64.img
    Found linux image: /boot/vmlinuz-4.19.5-200.fc28.x86_64
    Found initrd image: /boot/initramfs-4.19.5-200.fc28.x86_64.img
    Found linux image: /boot/vmlinuz-4.19.4-200.fc28.x86_64
    Found initrd image: /boot/initramfs-4.19.4-200.fc28.x86_64.img
    Found linux image: /boot/vmlinuz-0-rescue-5b4fe10ef4e44ce1a88c43e875d25fb2
    Found initrd image: /boot/initramfs-0-rescue-5b4fe10ef4e44ce1a88c43e875d25fb2.img
    Found Antergos Linux on /dev/sdb3
    done
    [[email protected] ***]# 
    
  • @Ge_Off
    Like @manuel already said, Grub2 on your internal drive (Fedora) is the host system in this case. Compare it with building A (Fedora) and building B (Antergos) that are built as two separate buildings, but both share the entrance of building A.
    In your case Building A is Fedora and the entrance is the Grub menu on your Fedora disk. To direct the computer to building B (Antergos) you have to make a gateway in the entrance of building A (Fedora) to reach building B (Antergos)
    That’s why you have to change the settings of the Grub menu of Fedora to reach Antergos.

  • @Ge_Off
    Does your machine support setting the booting drive in BIOS/Firmware?

    If so, then you could try that to see if Antergos works OK.
    And if it works, then you can boot to Antergos and give command

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    That should detect Fedora, too. And if all that works and you may boot also Fedora using Antergos’s grub, you may leave the BIOS/Firmware boot drive setting to that, until you find a way to boot Antergos from Fedora’s grub.

  • @Ge_Off
    Could you run command

    sudo cat /boot/grub2/grub.cfg | curl -F [email protected] https://ptpb.pw/?u=1
    

    and copy the returned short net address here?
    It shows what Fedora does about Antergos boot entry.

  • @Bryanpwo said in Antergos won't boot after manual partition install:

    @Ge_Off
    Like @manuel already said, Grub2 on your internal drive (Fedora) is the host system in this case. Compare it with building A (Fedora) and building B (Antergos) that are built as two separate buildings, but both share the entrance of building A.
    In your case Building A is Fedora and the entrance is the Grub menu on your Fedora disk. To direct the computer to building B (Antergos) you have to make a gateway in the entrance of building A (Fedora) to reach building B (Antergos)
    That’s why you have to change the settings of the Grub menu of Fedora to reach Antergos.

    When I start up my computer, I hit F12 to see the boot menu. I then select the external HDD that Antergos is installed on. This is exactly the same thing I did when trying Fedora when I was still on Win10. So I have trouble seeing why the bootloader on dev/sda has anything to do with my inability to boot from dev/sdb.

    When I select the usb HDD from the boot menu, absolutely nothing happens, and I’m immediately taken back to the boot menu.

    To extend your analogy, it would be like I’m on the road approaching both buildings and there’s an intersection with a sign that says I can completely bypass Building A. I go that way, but find that the road leads completely around Building B and back to the intersection.

  • @manuel said in Antergos won't boot after manual partition install:

    @Ge_Off
    Could you run command

    sudo cat /boot/grub2/grub.cfg | curl -F [email protected] https://ptpb.pw/?u=1
    

    and copy the returned short net address here?
    It shows what Fedora does about Antergos boot entry.

    Here’s the result:

    https://ptpb.pw/_kV-
    
  • @Ge_Off
    One Grubmenu is capable to handle several distro’s, if you use one central system for that, the OS that resides on your internal disk, it makes it easier just with one click, instead of going to your uefi menu to boot the one or the other.

  • @Ge_Off said in Antergos won't boot after manual partition install:

    I have attempted this at least a dozen times to no avail. Fedora has been my main OS for ~6 months, but I’m pretty oblivious to the majority of command line / terminal stuff, though I try to learn. I certainly know NOTHING about Arch commands and was hoping to ease into it.

    I was able to create a live USB, and I found that the instructions for doing so on the Antergos wiki were pretty clear, and that I could correctly infer which blanks to fill in.

    Since the no-install issue with auto-partitioning seems completely out of my control, what can I do about the non-boot issue? I don’t know how I would get an error message or log from a system that doesn’t boot. Could someone advise me on how to do that?

    Edit: More info: I have been attempting to install Antergos onto an external hard drive. Fedora is still installed on my laptop (Thinkpad P50). This is the exact same thing I did when I switched from Windows to Fedora. I lived with it for a while before making the jump. You could see this as a dual-boot, but ‘dual-boot’ usually infers ‘Windows’, so I’m hesitant to call it that…

    It is my opinion (mine only) that the problem is with the Cnchi installer.

    It’s just no good. It never has been any good and it’s my opinion (again) that it never will be any good.

    I have had a problem similar to yours and it’s entirely the fault of Cnchi. I have an Alienware AW17R3 computer which has two hard drives - a 256 GB SSD and a 1 TB Hard Drive (plus 16 GB RAM).

    No matter what I do (UEFI + Secure Boot activated [cleaned first], UEFI activated, Secure Boot disabled, BOTH disabled, using Legacy Boot), the OS seems to install after manually partitioning the installation but, after re-booting, the system WILL NOT boot up.

    My solution (and it WORKS!)? I installed Manjaro (with UEFI activated and Secure Boot disabled). Manjaro is very similar to Antergos (though I like Antergos better) and its installer WORKS properly. I now have Manjaro installed on that (former Windows) gaming computer.

    Cnchi seems to work on most computers with only one internal drive (at least that has been my experience), but when you have a computer with two or more drives or you attempt to manually partition the installation, well, forget about it!

    IF ONLY Antergos would abandon Cnchi and switch over to something like Calamares or a variant of GParted, Antergos would, again in my opinion, be the “perfect” GNU/Linux operating system.

    Thank you for considering my opinions. I hope that this post has been of some help to you. I repeat that I recommend that you install Manjaro for the “closest Antergos experience” possible at the present time.

    Lawrence

  • @lhb1142 if you want to talk about cnchi open a post up in the right section, and we can discuss about.

  • @Ge_Off
    The grub.cfg Fedora generated is incorrect for Antergos.
    If you look at it, the lines that start with word initrdefi have only one parameter, but they should have two! The initramfs parameter is missing, and grub cannot boot it properly.
    So add the missing parameter to the end of each such line: /initramfs-linux.img

boot319 partition41 manual11 Posts 23Views 479
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.