• \[Solved\] grub issue


    Hello,
    I’ve installed Antergos on a win 8.1 desktop.
    The installation instructions went well - I have a working version of Antergos.

    During installation, I partitioned the drive thus:
    now have the following:
    sda1: system restore (win)
    sda2: UEFI Boot
    sda3: Win8.1
    sda4: /home
    sda5: /
    sda6: swap
    sda7: system recovery partition (WIN8)

    When installing, I set the uefi boot option in the antergos installer to the windows UEFI Boot partition.
    In the uefi bios, it set the bootloader to read the grub antergos uefi volume first and the windows second. (otherwise windows just booted, skipping over antergos)

    Now that grub is loading, my issue is that the grub menu does not have the windows os listed. (When I used Ubuntu, I could use “update-grub” to add another os to the grub menu - but this is not available in antergos.)

    [b:3voifs16]So, how can I add Win8 to the grub menu?[/b:3voifs16]

    FYI: output of “ls -l /sys/firmware/efi”

    total 0  
    -r--r--r-- 1 root root 4096 Aug 11 11:38 config\_table  
    drwxr-xr-x 2 root root 0 Aug 11 11:22 efivars  
    -r--r--r-- 1 root root 4096 Aug 11 11:38 fw\_vendor  
    -r--r--r-- 1 root root 4096 Aug 11 11:38 runtime  
    drwxr-xr-x 12 root root 0 Aug 11 11:38 runtime-map  
    -r-------- 1 root root 4096 Aug 11 11:38 systab  
    
    
  • Hello,
    I’ve installed Antergos on a win 8.1 desktop.
    The installation instructions went well - I have a working version of Antergos.

    During installation, I partitioned the drive thus:
    now have the following:
    sda1: system restore (win)
    sda2: UEFI Boot
    sda3: Win8.1
    sda4: /home
    sda5: /
    sda6: swap
    sda7: system recovery partition (WIN8)

    When installing, I set the uefi boot option in the antergos installer to the windows UEFI Boot partition.
    In the uefi bios, it set the bootloader to read the grub antergos uefi volume first and the windows second. (otherwise windows just booted, skipping over antergos)

    Now that grub is loading, my issue is that the grub menu does not have the windows os listed. (When I used Ubuntu, I could use “update-grub” to add another os to the grub menu - but this is not available in antergos.)

    [b:3voifs16]So, how can I add Win8 to the grub menu?[/b:3voifs16]

    FYI: output of “ls -l /sys/firmware/efi”

    total 0  
    -r--r--r-- 1 root root 4096 Aug 11 11:38 config\_table  
    drwxr-xr-x 2 root root 0 Aug 11 11:22 efivars  
    -r--r--r-- 1 root root 4096 Aug 11 11:38 fw\_vendor  
    -r--r--r-- 1 root root 4096 Aug 11 11:38 runtime  
    drwxr-xr-x 12 root root 0 Aug 11 11:38 runtime-map  
    -r-------- 1 root root 4096 Aug 11 11:38 systab  
    
    
  • Hi,

    Ubuntus “update-grub” command is just a shortcut to the proper command that performs the task. You can run it like this:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Let me know if you have any questions

    Cheers!

  • Thank you - that solved my problem.

Posts 4Views 1226
Log in to reply