• Can't change application or icon theme in Deepin DE

    Did a quick search through the forum, didn’t see anyone else mention this. Cursor theme changes work.

    Any ideas?

  • I’ve tried Deepin this weekend in a virtual machine and on real hardware and I had the same problem, no matter what I tried, nothing worked. I think it has to do with the new version not being fully bug free, especially on Arch.

  • Thanks for confirming.

  • there have been 3 major updates to deepin 15.6 15.7 and now 15.8 and each one is worse than the last. seems developers can’t seem to make any progress. each version of the original deepin/debian acts completely different on my machine

    seems they had it so so ok in 15.6 but then changed everything with the menu that takes too many clicks. a menu should require one click to change categories and having to click on a back button takes away time from userspace

    they been spending too much time on the menu, panel and control settings and breaking small components on the way

    on my install i couldn’t change fonts or make them larger, i gave up soon after. deepin as it is now it’s just a gimmick desktop

  • @trytip your negative experiences are not my experience with running the full Deepin 15.8 distro (at least in a VM). Little things like how It handles 4K better than any other DE I’ve tried is winning me over (no xrandr fiddling). But, the Antergos version is a little out of sorts vs the actual distro. I’m not interested in running a Debian/Ubuntu based distro at this time, so I’ll stick with Antergos and Gnome 3.3 for now, and distro hop in VMs. But, the latest Deepin distro is very polished and not gimmicky to my sensibilities. And the English translations are unintentionally whimsical which adds to the charm. It reminds me of how I felt when using Xiaomi MI ROMs on Android 5 or 6 years ago. A nod to the mainstream iPhone and Android approaches of the day, but, with it’s own charm. Hopefully some of the small issues with Deepin on Antergos, like not being able to change the Numix Square icons, will get fixed in short time.

  • @bhtm1138
    I don’t know if it is related, but I checked Manjaro Deepin and they are still on version 15.7, so it’s probably a Deepin on Arch problem.

  • One thing I’ve noticed about Deepin on Arch is that the packages are not released at the same time. One evening you can have a lot of Deepin packages to update, and after installing them, you have all sorts of weird bugs. The next day, some other Deepin packages are updated, and after installing those everything works fine again. So it seems the issue often is that functionality depends on updates to specific packages that hasn’t been installed yet, or similar. When i run into these issues, they have been fixed in 99% of the time by just waiting a day and then running the software update again.

  • @stingray454
    Yes, that was my experience too, when Deepin was my daily driver a year ago. Somehow the Deepin updates are released in (not logical) chunks, so the one thing gets updated without the dependancy being updated.

deepin71 theme52 icon52 application36 Posts 8Views 1028
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.