• \[SOLVED\] Passing kernel arguments with UEFI boot


    Hi,
    I am not completely new to linux having dabbled with Fedora quite often, but I can’t figure this one out.

    My PC ‘retired’ last week and I have replaced it with a machine with an nVidia 750 ti, which I knew would could cause problems.

    However, when booting in BIOS mode I was able to pass nouveau.modeset=0 as a kernel option during install and initial boot and then enable the nVidia drivers, all good.

    But, seeing as my new computer had a UEFI enabled bios I tried a UEFI install.

    When booting the cd in UEFI mode I was presented with a menu with I think 4 options, one was Antergos boot, then there were 2 UEFI shells and maybe a 4th option.

    If I choose the Antergos boot, the install started straight away and I could see no way of amending the kernel options.

    I tried the UEFI shells but was unable to achieve anything useful.

    Now I know I should probably stick with the BIOS boot, but I would like to get this working if I can.

    By the way, very impressed with Antergos/Arch it seems very fast and stable.

    If I had to criticise one thing it would be the choice of lightdm as login manager, being unable to login without having to use both keyboard and mouse is a problem, easily fixed though.

    Yours t_j

  • Hi,
    I am not completely new to linux having dabbled with Fedora quite often, but I can’t figure this one out.

    My PC ‘retired’ last week and I have replaced it with a machine with an nVidia 750 ti, which I knew would could cause problems.

    However, when booting in BIOS mode I was able to pass nouveau.modeset=0 as a kernel option during install and initial boot and then enable the nVidia drivers, all good.

    But, seeing as my new computer had a UEFI enabled bios I tried a UEFI install.

    When booting the cd in UEFI mode I was presented with a menu with I think 4 options, one was Antergos boot, then there were 2 UEFI shells and maybe a 4th option.

    If I choose the Antergos boot, the install started straight away and I could see no way of amending the kernel options.

    I tried the UEFI shells but was unable to achieve anything useful.

    Now I know I should probably stick with the BIOS boot, but I would like to get this working if I can.

    By the way, very impressed with Antergos/Arch it seems very fast and stable.

    If I had to criticise one thing it would be the choice of lightdm as login manager, being unable to login without having to use both keyboard and mouse is a problem, easily fixed though.

    Yours t_j

  • Hi,

    You can add kernel options to the boot command by pressing " e " on the UEFI boot screen.

    @“tardis_junkie”:2gagvnwa said:

    If I had to criticise one thing it would be the choice of lightdm as login manager, being unable to login without having to use both keyboard and mouse is a problem, easily fixed though.[/quote:2gagvnwa]To be clear, this has nothing to do with LightDM. The behavior of the greeter theme has been modified just recently to allow pressing Enter or Spacebar to go directly to the password entry (provided that you don’t have multiple user accounts) The new version will be released into our package repo within the next few days.

    Cheers!

  • Thanks for that.

    I can’t believe it never occured to me to try that, oh well.

    Yours t_j

Posts 4Views 1739
Log in to reply