• Turned my PC on today and I get nothing but a black screen..


    Hey everyone! I’ve been using Antergos with the Cinnamon desktop environment on my PC for I think 6 or 7 months and haven’t had any many major issues until now. I’ve been using Linux for a while now but I’m still kind of a noob. I’m new to the community and forums so if I posted this in the wrong place or something sorry!

    So I went to turn on my PC this morning and it booted to black screen, and the only thing I can do is move my mouse cursor around. I remember yesterday I did an update and I think some Cinnamon stuff got updated so I’m assuming it broke Cinnamon. I tried to boot into the “fallback” mode and it booted up my wallpaper and said it had to restart Cinnamon, but I still couldn’t do anything but move my mouse cursor.

    If anybody has an idea on how to fix this without doing anything crazy like reinstalling the OS that would be great! Thank you!

  • @PhantomLord
    You should be able to start the machine in one of these ways:

    • when the machine gets stuck, press Ctrl-Alt-F2 (or F3-F6) to start terminal services
    • boot with the USB installer stick and chroot to the installed Antergos

    Chrooting is a bit trickier but still straightfoward. Boot with the stick, start terminal, give command

    lsblk -fm
    

    to see where the root partition is. Then switch to the root partition:

    su
    mount /dev/sdaX /mnt    # X is the number of your root partition
    arch-chroot /mnt
    

    and now you may give terminal commands to your Antergos.

    Either way, with terminal commands you may get it working. For example, install another kernel:

    sudo pacman -S linux-lts linux-lts-headers
    

    and try booting using that kernel.
    Also you might want to install Xfce packages:

    sudo pacman -S xfce4
    

    and try to boot to Xfce.

  • @manuel I did Ctrl+Alt+F2 and I can get into the terminal, but installing a different kernel didn’t fix it. I would prefer to not have to switch de’s, so I’m wondering if there’s maybe a command to delete and reinstall Cinnamon?

  • @PhantomLord
    Have you probed this command # pacman -Syu in terminal?

  • @zoli62 Yeah it didn’t help unfortunately.

  • @PhantomLord i would try installing another DM or another greeter for lightdm (what is installed by default with antergos style webkit greeter)

    https://antergos.com/wiki/desktops/installing-display-managers/

    lightdm-gtk-greeter - with lightdm-gtk-greeter-settings tool to configure it comfortable
    lightdm-slick-greeter (AUR) - what can be configured with lightdm-settings (AUR)

  • @PhantomLord said in Turned my PC on today and I get nothing but a black screen..:

    @zoli62 Yeah it didn’t help unfortunately.

    Copy here what error message you received with this command.

  • @zoli62 Oh the command works and updates my system, it just doesn’t solve the issue lol.

  • @PhantomLord

    Same thing append to me yesterday on kde.
    Ended in a black screen after reboot following update.

    Start your system with usb, or with ctrl-alt-f2 and run this command.
    (You need to be root)

    pacman -Qqn | pacman -S -
    

    Once finish, reboot normally

    It did the trick for me !

  • @PhantomLord
    Did you try to install XFCE4? sudo pacman -S xfce4 xfce4-goodies

  • It seems to me there is a spate of broken updates recently.
    In a terminal can you run
    sudo pacman -Qk | fgrep -v "0 missing files"
    If all is well, there is no output for this command set.
    Otherwise it will list packages with missing files, which can lead to weird behaviour (in my experience).
    Finally
    sudo pacman -Dk
    output should be
    No database errors have been found!

  • Ok so so far I’ve tried installing the LTS kernel, looked for kernel errors (didn’t find any), reinstalled Cinnamon, reinstalled the open source AMD GPU drivers (with the help of a Discord server) and Cinnamon still doesnt work. It keeps going into a “fallback” mode and crashes every time I restart it. Not sure what’s going on…

  • @loup001 Nope, that didn’t fix it.

    @zoli62 I’ll probably have to install another de at this point, but I think I want to try Mate instead because I don’t feel like customizing Xfce right now.

    @BlaiseD Tried both commands and there were no errors or bad packages.

  • Ok at this point I think I’m just going the completely remove Cinnamon and install Mate. Anyone know the commands for doing that (unless if there’s still a way to save Cinnamon)?

  • sudo pacman -S antergos-mate-meta

  • @joekamprad Alright, and I’m assuming this will remove Cinnamon too?

  • @PhantomLord cinnamon will stay installed…

  • Ok so I managed to remove Cinnamon and install Mate! When I log in, I get a window saying “An error was detected in the current theme that could interfere with the system login process.”. If I click “Load default theme” I get the black screen and cursor again, "and “Load fallback theme” brings me to a white screen with a shutdown button on the top right. Maybe I’m missing a package or something?

    Didn’t realize this would be a huge adventure lol! I’m going to take a break and continue tomorrow…

  • @zoli62 I’ll try to install a new DM tomorrow.

black82 screen18 today8 turned1 Posts 27Views 560
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.