• Error with updates


    Hi! I’m trying to update the packages but it doesn’t works in any way. The error that both terminal and package manager is (not literally) “the package is not valid or corrupted”.

    I tried to update the keys with:

    sudo pacman -Scc
    sudo pacman-key --refresh-keys
    

    This don’t works. Hope someone can help me!

  • Hi,
    do you know which packages are corrupted or invalid? Usually it’s only one or two that causes the problem, so you can put them on the ignore list. (sudo pacman -Syu -ignore followed by the package name.)

  • @Bryanpwo Hi! Thank you for reply :) I have found the package, it is

    deepin-api  3.5.0-1
    
  • Well, now you know and maybe you can try later (tomorrow or something) the package update was today, so maybe something went wrong and they’re trying to fix it.

  • @Bryanpwo Also today it can’t be installed :( I will try later!

  • Wait… This is strange! See this screenshot and focus on date!

  • When I’m looking at the updated package it’s deepin-api 3.9.0-1, that one has been created last thursday. So what is the exact error message?

  • 0_1542441520823_Bildschirmfoto vom 2018-11-17 08-58-26.png

    i would try do a full system update from terminal before using pamac again…

    sudo pacman -Syy
    sudo pacman -Syu

  • what is timedatectl status ? right time setting?

  • I opened an issue on github for the deepin-api package, hopefully someone will correct it soon , here is the issue that we are seeing:

    udo pacman -Syu
    [sudo] password for…
    :: Synchronizing package databases…
    antergos is up to date
    core is up to date
    extra is up to date
    community is up to date
    multilib is up to date
    :: Starting full system upgrade…
    error: could not open file /var/lib/pacman/local/deepin-api-3.5.0-1/desc: No such file or directory
    resolving dependencies…
    looking for conflicting packages…
    warning: could not fully load metadata for package deepin-api-3.5.0-1
    error: failed to prepare transaction (invalid or corrupted package)

  • @bishoptf said in Error with updates:

    I opened an issue on github for the deepin-api package

    as they do not maintain the package for archlinux they can not help on this issue there ;)

    @Hirokami @bishoptf actual version on archlinux community is: deepin-api 3.9.0-1

    So the problem is on your side, as your system seem to have a very outdated version installed…

    you can try download it manually and install it manually:

    https://www.archlinux.org/packages/community/x86_64/deepin-api/download/

    then install from terminal:

    sudo pacman -U deepin-api-3.9.0-1-x86_64.pkg.tar.xz

    This will may bring also error message up, post it here and we will get it solved…

  • @bishoptf said in Error with updates:

    /var/lib/pacman/local/deepin-api-3.5.0-1

    look at https://www.archlinux.org/mirrors/status/ and check your /etc/pacman.d/mirrorlist , look at the first mayby second mirror list, is that repo on the out of sync mirror ?

  • @joekamprad

    I understand what you are saying I am just letting you know of the error, this is a straight antergos load with very minimal community packages, almost always getting updates via GUI. deepin-api 3.9.0-1 is the one that they are trying to upgrade too, not sure how it broke via pacman since pac shouldn’t let this happen but something somewhere broke the package.

    Felix Yan is the package maintainer and the same person on github, going to wait and see if he replies, it does appear to be an issue with the existing package 3.5.0-1.

  • @bishoptf IIRC I saw something similar when an upgrade cycle went wrong crashed or timed-out, not sure. In my case it was with kwin.
    I finally solved by

    sudo rm /var/lib/pacman/local/kwin-5.14.3-1 -rf
    sudo pacman -S kwin --force
    

    I think --overwrite instead of --force is probably more appropriate (–force is deprecated)
    So in your case

    sudo rm /var/lib/pacman/local/deepin-api*
    sudo pacman -S deepin-api --overwrite
    

    might fix the problem.

    However before you do that run pacman -Qk and pacman -Dk and see if that highlights any issues. See https://wiki.archlinux.org/index.php/Pacman/Rosetta for descriptions.

    In my case packman -Dk showed that 0 files were installed for kwin.

  • @joekamprad said in Error with updates:

    @bishoptf said in Error with updates:

    I opened an issue on github for the deepin-api package

    as they do not maintain the package for archlinux they can not help on this issue there ;)

    @Hirokami @bishoptf actual version on archlinux community is: deepin-api 3.9.0-1

    So the problem is on your side, as your system seem to have a very outdated version installed…

    you can try download it manually and install it manually:

    https://www.archlinux.org/packages/community/x86_64/deepin-api/download/

    then install from terminal:

    sudo pacman -U deepin-api-3.9.0-1-x86_64.pkg.tar.xz

    This will may bring also error message up, post it here and we will get it solved…

    Same error its looking for a description file or directory for 3.5.0-1:

    error: could not open file /var/lib/pacman/local/deepin-api-3.5.0-1/desc: No such file or directory
    warning: could not fully load metadata for package deepin-api-3.5.0-1
    error: failed to prepare transaction (invalid or corrupted package)

  • @BlaiseD said in Error with updates:

    @bishoptf IIRC I saw something similar when an upgrade cycle went wrong crashed or timed-out, not sure. In my case it was with kwin.
    I finally solved by

    sudo rm /var/lib/pacman/local/kwin-5.14.3-1 -rf
    sudo pacman -S kwin --force
    

    I think --overwrite instead of --force is probably more appropriate (–force is deprecated)
    So in your case

    sudo rm /var/lib/pacman/local/deepin-api*
    sudo pacman -S deepin-api --overwrite
    

    might fix the problem.

    However before you do that run pacman -Qk and pacman -Dk and see if that highlights any issues. See https://wiki.archlinux.org/index.php/Pacman/Rosetta for descriptions.

    In my case packman -Dk showed that 0 files were installed for kwin.

    pacman -Qk appears to be good, however

    pacman -Dk
    error: ‘deepin-api-3.5.0-1’: description file is missing
    error: ‘deepin-api-3.5.0-1’: file list is missing

    Thats the problem, so maybe let me see if I can find the original 3.5.0-1 and re-install that…

  • Here is the history:

    Age Commit message (Expand) Author
    3 days upgpkg: deepin-api 3.9.0-1 felixonmars
    4 days upgpkg: deepin-api 3.8.0-1 felixonmars
    5 days upgpkg: deepin-api 3.7.0-1 felixonmars
    6 days upgpkg: deepin-api 3.5.0-2 felixonmars
    10 days upgpkg: deepin-api 3.5.0-1 felixonmars
    2018-11-01 upgpkg: deepin-api 3.4.0-1 felixonmars

    Now that I think about it I did have one major update that was funky, i bet it was that update that messed things up, just trying to figure out what is the best way to resolve.

  • I am not expert, but sometimes that happens to me went:

    I am connected to an internet that have too much security settings like a public space or an institutional internet.

    or, the computer is kinda old and tents to happen. I bought a computer last week and I am not having the problem I usually had with my 7 years old computer.

    other than that I am completely clueless…

  • @BlaiseD said in Error with updates:

    @bishoptf IIRC I saw something similar when an upgrade cycle went wrong crashed or timed-out, not sure. In my case it was with kwin.
    I finally solved by

    sudo rm /var/lib/pacman/local/kwin-5.14.3-1 -rf
    sudo pacman -S kwin --force
    

    I think --overwrite instead of --force is probably more appropriate (–force is deprecated)
    So in your case

    sudo rm /var/lib/pacman/local/deepin-api*
    sudo pacman -S deepin-api --overwrite
    

    might fix the problem.

    However before you do that run pacman -Qk and pacman -Dk and see if that highlights any issues. See https://wiki.archlinux.org/index.php/Pacman/Rosetta for descriptions.

    In my case packman -Dk showed that 0 files were installed for kwin.

    That did the trick, removed the directory and re-applied. Just FYI --force is deprecated but works , using --overwrite requires you to provide the directory path, I was lazy and did the force.

    If anyone else has the issues, delete and re-install latest version.

    Thanks guys :)

error334 updates71 Posts 22Views 951
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.