• System Activity - Baloo, high ram usage


    Just an fyi.

    Since update past few days, started having system ram getting sucked up by a file called baloo, over 4 GB of ram shooting mem usage to 71%.

    Idk if it’s from a specific program causing it or not, but the rig is slow as all get out until I shut it off.

    pamac says it’s for metadata so idk if it’s related to vlc or not but I use it pretty much daily watching videos.

    Just throwing this out there making it known for anyone else that might have noticed something.

  • baloo can be controlled using System Settings and selecting Search, then either disable File Search or index file content or add to Do not search in these locations.
    I suspect indexing file content is what consumes CPU and memory.
    I tried a quick google for clients of baloo and did not find much other than krunner and elisa.
    Not sure what the effect of turning off index file content would be.
    In my case, almost all of my data (under /home/username) is not on the partition mounted as / and the default search settings seem to exclude all other mounted partitions.
    So almost all of my files and content is not indexed by baloo.
    I haven’t noticed any missing functionality but that may just be the way I do stuff. I’m old school, and use find and grep to find stuff.

  • baloo help documentation states that by default only $HOME folder in indexed.

  • AH thankyou for the info, as I booted today noticed it was high again before loading anything so that helps…doing an update again now and will reboot to see what happens.

  • hmmm seems to be a little better after update & reboot.

    ram usage hung around 52% instead of 75% like before, but shutting it off in system activity dropped it from 52% to 18%

    but then again, maybe it hadn’t run long enough to get too high and start lagging system…It knows I’m watching it now lol

    I’ll keep an eye on it

  • After watching this continue on my system for a few months, the problem never went away, so decided to start looking into it because I’d fallen into the habit of just disabling it in the system activity after booting.

    I’ve found traces of this this giving people ram issues back to 2015 as far as I’ve seen.
    What’s interesting, we all had KDE in common in the instances I’d seen so if that helps anyone idk.

    What fixed it for me was running

    balooctl disable
    balooctl enable
    

    the file indexer ran for a bit, I rebooted, not an issues since a couple days ago when I did it.

    The solution was the same in 2017 in this forum, someone had an issue with baloo_file_extractor mine was baloo_file
    https://forum.antergos.com/topic/8569/baloo_file_extractor-kde-plasma-5-9-3

    I never saw anything in searches that could suggest what could cause this, the only thing I got was that it seemed to strike people randomly with KDE.
    Maybe certain hardware not likeing an update at one point caused it idk.

    Anyway, the super high ram & cpu usage isn’t at 75% anymore , hope it helps.

system139 high6 baloo3 activity1 Posts 6Views 223
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.