• Unable to boot properly after update

    I’m not really sure what the issue is since the system has been working reliably since august. I came home from work after setting antergos to update and returned to a black screen.

    I’m afraid I can’t give much more information than this because I haven’t gottem very deep into this stuff, and I don’t even know where to start to describe the problem or troubleshooting.

    Any help in getting this install working again would be greatly appreciated.

    Seems I can’t upload images from my phone so this will have to do.

    Whenever I boot up the PC, as linux tries to start I get a bunch of stuff like this:

    starting version 239
    [ OK ] started authorization manager
    [ OK ] started modem manager
    [ OK ] reached multi-user system
    [ OK ] reached target graphical interface

    And so on. But eventually it just stops, and it does so at a different point on every boot attempt. It looks like something is still running so it’s not a total lock up, but I have no idea on where to go from here to get this install working again.

  • @gabriel-t
    first, i would not update computer and then leave. most likely the updates wanted some human interaction and then it stalled. you may recover or may not, can’t say but you can try

    second, boot with your live antergos. close ALL the programs and connect to the internet then
    open terminal and type:
    mount /dev/sda4 /mnt replace sda4 with your /root partition and number
    arch-chroot /mnt
    pacman -Syyu
    reboot and pray to Linus

  • @trytip
    ok sorry for the late reply, and thanks for the advice. First week on a new job and I didn’t have the patience to deal with this problem. Using a new account because the password reset tool here isn’t working for me, and I can’t log in to the old account.

    So, I tried to do what you suggested. When I try the second command I get “mount: /mnt: unknown filesystem type ‘LVM2_member’”. Any idea what would cause this, and what it means?

    After some digging around I found out that I can still log in, didn’t know about the terminal shortcut.

    • I can’t update the system because it can’t connect to any databases
    • plasmashell won’t launch
    • some CLI applications like protonvpn and rslsync appear to work

    Still no progress, but hoping someone can help me figure this out.

  • can’t help if i don’t see your commands. once you boot into your live antergos tune the commands then post them here
    i just tried it in mine (i have help packages so i didn’t update)

    liveuser ~ $ su
    root /home/liveuser # mount /dev/sdb4 /mnt
    root /home/liveuser # arch-chroot /mnt
    root / # pacman -Syyu
    :: Synchronizing package databases...
     core                     133.2 KiB   454K/s 00:00 [----------------------] 100%
     extra                   1680.6 KiB  1334K/s 00:01 [----------------------] 100%
     community                  4.7 MiB   657K/s 00:07 [----------------------] 100%
     multilib                 177.8 KiB  1400K/s 00:00 [----------------------] 100%
     archlinuxfr               11.4 KiB  72.8K/s 00:00 [----------------------] 100%
    :: Starting full system upgrade...
    warning: dbus: ignoring package upgrade (1.12.10-1 => 1.12.10-2)
    warning: thunar: ignoring package upgrade (1.6.15-1 => 1.8.2-1)
    warning: thunar-archive-plugin: ignoring package upgrade (0.3.1-7 => 0.4.0-1)
    warning: wine: ignoring package upgrade (3.0-1 => 3.20-1)
    resolving dependencies...
    looking for conflicting packages...
  • @gabriel-t2 said in Unable to boot properly after update:


    so may you are running an encrypted system setup? or a LVM2 volume group?
    You will need to open/decrypt filesystem before using arch-chroot to get into the installed system…

  • @joekamprad I don’t recall setting up encryption earlier this year. Last time I did so I remember being prompted for a password upon booting up, but I haven’t had to do that lately so I imagine that the drive is still unencrypted.

    @trytip The following is from the live OS on my USB

    [[email protected] ~]$ su
    [[email protected] antergos]# mount /dev/sdc2 /mnt
    mount: /mnt: unknown filesystem type ‘LVM2_member’.

  • my memory lacks function 😆 can you boot at all into system, you say “properly” does it mean you can get to a desktop? if not does this command output anything in live?

    lsblk -o NAME,TYPE,FSTYPE
  • @trytip I meant “boot properly” as a clumsy way of saying saying “boot into GUI (KDE)”

    When I type the lsblk command in the live terminal I get this

    lsblk: unknown column: NAME,

  • Curious, it works for me. However just lsblk will yield the required information as well.

boot320 unable76 properly25 Posts 9Views 572
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.