• Kein Log-in möglich - Loop


    Hallo liebe Gemeinde,
    erst einmal ein freundliches “Hallo” an alle :-).
    Ich nutze schon seit vielen Jahren Linux, allerdings bin ich nach wie vor Neuling :-/. Bei Problemen suche ich im Netz nach Lösungen und versuche die Tipps nach Möglichkeit umzusetzen. Mein Englisch ist allerdings nicht gut, so dass es mal besser, mal schlechter klappt.
    Verzeiht es mir also bitte, wenn ich “dumme” Fragen stellen sollte :-). Denn zurück zu Win ist für mich absolut keine Option. Soviel zu mir …
    Nun aber zu meinem Problem:
    nach unendlich vielen Versuchen, Recherche und der Benutzung der Minimal-Version ist es mir endlich (mittels Vesa Fallback) gelungen, Antergos zu installieren - so ziemlich die einzige Disto, die ich auf meinem Elitebook 8740w mit Nvidia Quadro FX 2800m installieren konnte. Bisher nutzte ich Fedora (seit Version 19). Das Installieren des Nvidia-Treibers funktionierte nach anfänglichen Schwierigkeiten recht gut. Bis Version 27. Ab da war es - zumindest für mich - nicht mehr möglich. Ich versuchte verschiedene Distributionen ohne Erfolg - auch Arch mittels verschiedener Installer. Aber sämtliche Installations-ISO produzierten einen schwarzen Bildschirm. Arch konnte ich zwar mittels Feliz installieren, nach dem Startbildschirm wurde es aber wieder schwarz … :-(. Eine Lösung für das Problem habe ich leider nicht gefunden. Ich kam noch nicht einmal in RL3, um Nvidia zu installieren. Nun hat es mit Antergos nach oben erwähnter Methode endlich geklappt :-D! Aber … ein Log-in nicht möglich. Sobald ich ein Passwort eingebe, erscheint kurz ein schwarzer Bildschirm und dann wieder der Log-in-Screen. Das Passwort ist aber korrekt ;-).
    Hat jemand eine Idee, was ich tun könnte?
    Im RL3 konnte ich mich sowohl als Benutzer als auch als root einloggen und ein Update machen (pacman -Syu ), allerdings scheint das System auf dem neusten Stand zu sein. Das war ein Tipp, den ich im Netz gefunden habe. Funktioniert bei mir aber wohl nicht.
    Vielen Dank im Voraus!

  • @Newbie2018 said in Kein Log-in möglich - Loop:

    Nvidia Quadro FX 2800m

    https://www.nvidia.de/drivers/results/135242

    ist ja eine legacy Karte die den nvidia 340xx braucht da sie vom aktuellen nvidia Treiber nicht mehr unterstützt wird… https://www.archlinux.org/packages/extra/x86_64/nvidia-340xx/

    wiki dazu: https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/

    Sollte aber auch recht gut mit dem open source Treiber funktionieren (nouveau)
    Ohne zu wissen welchen Treiber du wie genau installiert hast kann ich noch nicht mehr helfen…

  • Vielen Dank für die rasche Antwort!
    Ich habe noch nichts installiert - bis auf das Antergos selbst. Konnte mich ja nicht einloggen.
    Das heißt also, dass der Loop mit der Gafikkarte zu tun hat und ich den Nvidia-Treiber installieren muss, um mich einloggen zu können?

  • hast du GNOME gewählt ? dann probiere mal Gnome Xorg Session zu wählen beim login screen…
    und bei der Installation hast du auch nicht ausgewählt Treiber (Nvidia) zu installieren? wie gesagt der nouveau Treiber müsste funktionieren

  • sonst geh mal mit Strg+Alt+F2 ins TTY und gucke ob der falsche Treiber installiert ist:

    pacman -Qs nvidia
    
  • Bei der Installation habe ich Gnome und die Nvidia-Treiber mit ausgewählt. Auch mit Xorg habe ich es probiert - gleiches Ergebnis. Mit Strg+Alt+F2 bleibt der Bildschirm schwarz. Ich kann lediglich direkt im Startbildschirm mit “e” editieren und hinter “quiet” eine 3 setzen.
    Wenn ich “pacman -Qs nvidia” eingebe, erhalte ich folgendes:
    0_1542055323405_IMG_20181112_210528.jpg .
    Der richtige Treiber ist wohl installiert …

  • ja richtiger Treiber… kannst du versuchen gdm zu installieren und zu aktivieren?

    sudo pacman -S gdm
    sudo systemctl -f enable gdm

    reboot

  • 0_1542055884398_Bildschirmfoto vom 2018-11-12 21-50-42.png
    /home/ich existiert nicht könnte auch das Problem verursachen…

    eventuell ist dein Benutzer nicht richtig angelegt…

    Wenn du dich einloggen kannst im CLI/textbasiert kannst du versuchen das einfach an zu legen:

    sudo mkdir /home/ich
    sudo chown -R ich /home/ich

  • Nach

    sudo pacman -S gdm
    sudo systemctl -f enable gdm

    kam Folgendes:
    0_1542057626028_IMG_20181112_220224.jpg

    Habe jetzt den Gnome-Log-in-Screen … und kann mich einloggen :-D!
    Vielen Dank für deine Hilfe :-)!

  • Dann auf keinen Fall deinen Home Ordner anlegen, wie ich es vorher angeregt hatte!

    Schön das Du wieder drinnen bist!

  • Hast du Verschlüsselt installiert?

  • Hast du Verschlüsselt installiert?

  • Liebe Gemeinde,
    habe wieder das gleiche Problem - ich kann mich nach einem Update vor einigen Tagen leider wieder nicht anmelden. Habe sowohl Gnome als auch Gnome Classic probiert, mehr habe ich nicht zur Auswahl.
    In der Zwischenzeit lief alles perfekt, so dass ich nicht mehr hier war.

    Habe versucht, einen neuen Post zu eröffnen, bekomme aber immer eine Akismet-Spam-Nachricht … Aber vielleicht ist eine Fortführung des alten Post ja auch sinnvoll.

    Weiß jemand Rat?
    Besten Dank im Voraus!

    PS @joekamprad : Ja, ich hatte verschlüsselt installiert. Bin die Antwort schuldig geblieben, weil ich nicht mehr hier war.

  • sudo systemctl -f enable lightdm
    sudo systemctl reboot
    vice versa …

    Kann aber auch ein Problem mit der Verschlüsselung sein, eventuell zfs gewählt zusätzlich?

  • Ich kann zwar jetzt Gnome unter Xorg anwählen, komme aber leider ich immer noch nicht rein :-/.
    Weiß nicht, ob das wichtig ist, aber der Bildschirm wird kurz schwarz, die Maus erscheint unten rechts in der Ecke, dann wird der Bildschirm wieder schwarz und die Maus ist wieder, wie zuvor, in der Mitte des Bildschirms.

    Bewusst habe ich zfs nicht gewählt (weiß gar nicht, was das ist). Habe einfach nur mit LUKS verschlüsselt.

  • sudo pacman -Syyu
    sudo pacman -S linux linux-headers
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    –> reboot

    wenn das nicht klappt nvidia treiber neu instalieren
    sudo nvidia-installer
    –> reboot

    Wenn das auch nicht klappt zum nouveau Treiber wechseln:

    sudo nvidia-installer -n

    –> reboot

  • Das Erste hat leider nicht geklappt.
    Bei

    sudo nvidia-installer
    

    bekomme ich die Meldung

    sudo: nvidia-installer: Befehl nicht gefunden
    

    Nouveau habe ich noch nicht probiert, schätze aber, ich bekomme die gleiche Meldung.

  • @newbie2019
    Zuerst installieren:
    sudo pacman -S nvidia-installer

  • Hmmm …

    IMG_20190323_123554.jpg

    Wenn ich nouveau probiere, bekomme ich eine ähnliche Meldung:

    IMG_20190323_131656.jpg

    Und nun?

  • Weiß keiner Rat?

    Die Auflösung sieht jetzt so aus:

    IMG_20190324_112709.jpg

    Hatte versucht wieder Nvidia “blind” zu installieren, da ich nach dem Passwort nichts mehr sehen kann. Ist ja eigentlich nicht kompliziert: Passwort, die o.g. Befehlszeile, Passwort. War wohl nix - der Bildschirm bleibt jetzt komplett schwarz, wenn ich normal boote - toll …

loop10 log-in5 möglich3 kein2 Posts 41Views 429
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.