• update breaks KDE icon task manager

    Update yesterday broke my task manager and main panel was just an icon of two little windows, clicking on it gives me the pop-up of:

    Error loading QML file: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/main.qml:26:1: plugin cannot be loaded for module "org.kde.taskmanager": Cannot load library /usr/lib/qt/qml/org/kde/taskmanager/libtaskmanagerplugin.so: (libprocesscore.so.7: cannot open shared object file: No such file or directory)

    possible solution that worked for me to fix fix libksysguard

    sudo rm /var/lib/pacman/local/libksysguard-5.14.3-1/ -rf
    sudo pacman -S libksysguard --force

    I took this from solution from: https://www.reddit.com/r/kde/comments/9uu1zx/iconsonly_task_manager_and_regular_task_manager/

    posting in case others have problems.

  • @Ant thanks, that worked for my laptop sadly not for my desktop box.
    At the moment Antergos KDE on the desktop is unusable, the window decorations (title, maximise, minimise…) are not drawn, windows are not resizable, and cannot be focused on by reliably by clicking, and Alt-tab, Alt-F4 do not work either.
    The difference between the two installations?
    Desktop box antergos was installed 9 months ago has been running superbly during that time.
    The laptop installation is relatively new about 3 months now.

    I did try using a virgin user home directory to see if that would fix but it didn’t.
    Does any one have any ideas which log files are worth looking at?

  • Might be issues with kwin, if use pacman -S I get

    error: could not open file /var/lib/pacman/local/kwin-5.14.3-1/desc: No such file or directory

    sadly googling didn’t get any hits.

    kwin isn’t installed, and trying to install failed
    trying to reinstall kwin failed

    sudo pacman -S kwin --overwrite \*
    warning: kwin-5.14.3-1 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    error: could not open file /var/lib/pacman/local/kwin-5.14.3-1/desc: No such file or directory
    warning: could not fully load metadata for package kwin-5.14.3-1
    error: failed to prepare transaction (invalid or corrupted package)
  • Phew! managed to fix it, by searching the forum for posts on invalid or corrupted packages.
    For the record here is the set of commands I used gleaned from history (logged in as root hence no sudo)

      491  pacman-key --init
      492  pacman-key --populate archlinux antergos
      493  pacman-key --refresh-keys
      494  pacman -Syyu
      495  pacman -Scc
      497  pacman-key --refresh-keys
      499  pacman -S antergos-kde-meta --overwrite \*

    I should have done the pacman -Scc at the beginning.

    I do remember that I fired off an update using the GUI (pamac-manager) and continued using the computer to do other stuff.
    Thinking back now the pamac-manager window disappeared at some point,
    and I did not see the usual notification for update completion.
    A few hours later, I wasn’t alert to the unusual situation and shut the system down (probably from the terminal).
    When I tried to boot again I had problems.
    Silly me.

  • Bah! I managed to deceive myself into thinking I’d fixed the issue.
    I’m thinking reinstalling kde might fix the issue.
    Is uninstalling antergos-kde-meta and then reinstalling a viable solution?
    Any tips on the best way to do this?

  • Yay! Fixed.
    I should have RTFM, https://wiki.archlinux.org/index.php/Pacman/Rosetta

    I used pacman -Qk and pacman -Dk and reinstalled everything package that was being complained against.
    pacman -Dk showed that zero files were installed for kwin!

    Not sure exactly how that happened, either update was taking too long as previously explained or update crashed.

    Fixed by

    sudo rm /var/lib/pacman/local/libksysguard-5.14.3-1/ -rf
    sudo rm /var/lib/pacman/local/kemoticons* -rf
    sudo rm /var/lib/pacman/local/kwin-5.14.3-1 -rf
    sudo pacman -S kwin libksysguard kemoticons --force

    et voila, all appears to be normal!

  • @BlaiseD Wow thanks! I had a different problem but it turned out it had a similar cause.

    After a botched system update I could not get past the lightdm login screen anymore. The screen went black with a cursor, flickered for a moment, and I was thrown back to the login screen.

    pacman -Dk revealed problems with kauth so as per your explanation I rm’ed the /var/lib kauth folder, and after a pacman -S kauth --force with a reboot I had my system back.

    Million thanks for the solution!

  • Excellent! I am glad my post was of some service.

kde206 icon52 breaks38 task4 Posts 8Views 656
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.