I had two issues with the most recent attempts to install Antergos

  1. While trying to install Antergos to a desktop over a net connection that blocks accesses from most foreign countries, I was unable to get past the mirror selection - it hung because cnchi demanded to access an IP in either India or the Indian Ocean, probably something used to determine the location of the installer for language, keyboard layout, time zone, etc… Ultimately, I gave up trying to install over the hardline connection and switched to wireless, but…

  2. I had a heck of a time with Antergos and wireless networking. At first, none of my USB wireless cards would work. They could see the access points, but they could not associate with them. This was to a newish ASUS AC3200 router with the latest Merlin firmware updates. It is set for WPA and WPA2 security with a long but not unreasonable passphrase. This router supports A?, B, G, N, and AC (up to 3200) adapters.The wireless cards were:

  • DLink DWA-140 B2 (using the rt2800usb driver). [N300]
  • Netgear WG111v2. [G or 54]
  • AnyPoint Wireless II Network [B or 11]

All of the cards could see the main access point, but none could associate. After a few hours of digging, I heard over on some Arch Linux and Ubuntu forums that the extra long udev names might be interfering with the ability of the wireless cards to associate with the access point (AP). The solution was, at boot time, to put

net.ifnames=0 biosdevnames=0

on the Antergos boot line (I think the command said ‘Advanced Options’ or something). I had to disable KMS for my video card, anyway, so I was already on there. This worked, the cards appeared as wlan0 and so on. I was able to get Antergos installed on my USB HD for testing at that point.

After Antergos was installed, my AP could not be connected to (I opted not to use that on my default kernel). I didn’t want to use that on my default install, so I opted for the Arch Linux directions to permanently assign names to my wifi cards, found here:

[Arch Docs]
Change interface name
Note: When changing the naming scheme, do not forget to update all network-related configuration files and custom systemd unit files to reflect the change.

You can change the device name by defining the name manually with an udev-rule. For example:
/etc/udev/rules.d/10-network.rules

SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="aa:bb:cc:dd:ee:ff", NAME="wifi0"
SUBSYSTEM=="net", ACTION=="add", ATTR{address}=="ff:ee:dd:cc:bb:aa", NAME="wifi1"

These rules will be applied automatically at boot.

To test your rules, they can be triggered directly from userspace, e.g. with udevadm --debug test /sys/DEVPATH. >Remember to first take down the interface you are trying to rename (e.g. ip link set enp1s0 down).

Note: When choosing the static names it should be avoided to use names in the format of “ethX” and “wlanX”, because this may lead to race conditions between the kernel and udev during boot. Instead, it is better to use interface names that are not used by the kernel as default, e.g.: net0, net1, wifi0, wifi1. For further details please see the systemd documentation.
[/Arch Docs]

One more minor complaint: The D-Link card had a dynamic MAC when its firmware gets loaded, so instead of associating the wifi1 with a MAC address, I associated it with that wireless driver (rt2800usb) instead. I only have one, so it shouldn’t be an issue. If you have two wireless cards that use the same driver, this shouldn’t work. The command looked something like this:

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="rt2800usb", NAME="wifi3"

Hope all that helps someone.