• Audacity not working after alsa-lib updated see bug report


    Just an FYI

    I use Audacity to monitor streaming audio playing on the desktop, then record it. This stopped working recently. Did some research, and found out that alsa-lib-1.1.7-1 has a bug in it. See bug report here:

    Arch bug report

    Went to The Arch Archive

    And downloaded and installed alsa-lib-1.1.6-1 and fixed the problem.
    So if you are experiencing audio problems, you might want to take this into consideration.

  • @pudge
    i had to downgrade all my alsa, i used the downgrade package and downgraded all from 1.1.7 to the first 1.1.6

    upgraded alsa-lib (1.1.6-1 -> 1.1.7-1)
    upgraded alsa-plugins (1.1.6-2 -> 1.1.7-1)
    upgraded alsa-utils (1.1.6-1 -> 1.1.7-1)
    upgraded lib32-alsa-lib (1.1.6-1 -> 1.1.7-1)
    upgraded lib32-alsa-plugins (1.1.6-1 -> 1.1.7-1)
    
  • @trytip said in Audacity not working after alsa-lib updated see bug report:

    @pudge
    i had to downgrade all my alsa, i used the downgrade package and downgraded all from 1.1.7 to the first 1.1.6

    In Fedora, dnf has an --exclude option that updates everything except the exclusion. You can exclude a package, a group, or a glob.

    Now i have to read the man pages to figure out how to do this with pacman until alsa-lib gets fixed.

  • there are a few ways to block something from being updated. i won’t show you how to do it in pamac because i use an older version (pamac-aur-5.1.1-3 because it’s much simpler)
    if you install downgrade and you use downgrade alsa-lib it will give an option to get an older version and at the end of installation it will ask you if you want it blocked which will add an exception in /etc/pacman.conf or you can edit the file yourself:
    so far i will just keep an eye out on the alsa packages and not upgrade them since i upgrade using pamac and i have control what to keep back

    but i do edit /etc/pacman.conf quite often manually, here’s what i keep back:

    IgnorePkg   = pamac-aur dbus wine thunar thunar-archive-plugin qbittorrent
    #IgnoreGroup =
    
  • @trytip said in Audacity not working after alsa-lib updated see bug report:

    if you install downgrade and you use downgrade alsa-lib it will give an option to get an older version and at the end of installation it will ask you if you want it blocked which will add an exception in /etc/pacman.conf or you can edit the file yourself:

    Nice. I didn’t know about the “downgrade” package. That makes it a lot faster and simpler.

    Thanks for the tip.

updated9 report4 audacity1 alsa-lib1 Posts 5Views 84
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.