• Unable to get Plymouth Splash Screen Working

    I’ve been trying to get a splash screen working similar to Ubuntu or Fedora with Plymouth but I can’t see to get it to do anything.

    I followed the instructions on the arch wiki page but nothing happened at all it seems.

    I also can’t find much current information on it.

  • would be interesting to get it working, as i hear it can work again…

    what exactly is your configuration? GPU / framebuffer /config files?

  • My GPU is Intel integrated although I do have an nVidia 970m but I never use it, not sure if that would cause an issue.

    I’ve see framebuffer mentioned multiple times and I’m not really sure what that is exactly, could you elaborate?

    My config files are pretty much just following the ArchWiki for Plymouth. Added the hook to /etc/mkinitcpio.conf and i915 for Intel graphics to the modules. Added ‘splash’ to the grub kernel parameters (quiet was already there). I also switched to lightdm-plymouth. (Pretty sure it still should work with regular lightdm although neither worked so it’s kind of a moot point)

    I had read that people only had success using gdm-plymouth but when I switched to that it would not fully boot. (I probably overlooked some necessary config.)

  • also plymouth in the hooks ? i prefer my self on silent boot :) plymouth-lightdm regulary makes the gab from bootscreen to lightdm smaller, is also gdm-plymouth, to show up in bootscreen, in hooks of mkinitcpio.conf , also done ?

  • Yes it is, I put it in the hooks and rebuilt the init or whatever it is.

  • I will give it a try next days, and come back here…

  • @PoLoMoTo you can remind me if i forget :)

  • which plymouth version do you use, plymouth from the repo’s or aur ?

  • As i was thinking before i got problems getting it running with nvidia driver … also nouveau only gives me textfallback…

  • @joekamprad has that to do on video driver? mayby i got a old nvidia mayby other rulez… never had those really even with current silent boot i run, only by some change or issue it shows text otherwise is mine boot straight black also no fsck showing, only logout i have to figure… sometimes you must run your video early

  • also my system starts up in 3.5 seconds … ;) and is a BIOS system… may i try to play on this into virtualbox…

  • @ringo32 do you use Plymouth from Antergos Repo or the one from AUR?

  • @joekamprad i dont use plymouth anymore , silentboot is fine, i think now with users with efi bios can boot up the vendor logo with linux 4.19 ? my self got old machine dont see it :p try to find info on that but boot is fast enough with sdd root, silent is nice :)

  • [plymouth uvesafb nvidia]

unable76 plymouth5 splash3 Posts 14Views 444
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.