• solved Package corrupted in Gnome - Unable to boot

    Hey guys, I’m new to the community but I’ve been using Antergos for several months now and I have to say I really enjoy it. I’ve been playing around with it a lot and have learned a boatload; however just today i came across an issue that I’m having trouble resolving on my own. I’m new to the whole Arch Linux scene which is which I went with Antergos to begin with as a decent introduction. Anyways my point is, i’m still probably what many of you would consider a noob so i apologize in advance if I’m missing something obvious. Anyways my issue is this:

    I don’t dual boot. I completely removed Windows 10 and just run Antergos as my main OS. So earlier today I was working on some stuff, browsing the web, doing some research, everything was fine. As i was working however, I ran a system update through the GUI package manager in the background (I know I could have just run sudo pacman -Syu but i wanted to omit a particular package update so un-checking the box seemed like an easy way to get the job done.). But still nothing really out of the ordinary. Here’s where everything went haywire, the system downloaded the updates from all of the relevant repositories as i’ve done probably hundreds of times before and during what i assume was the installation portion, suddenly my background went black, my terminal and browser windows became unresponsive and the whole system crashed. On reboot, i start off with the usual 3 options:
    -Reboot into firmware interface (BIOS)

    Normally this is where systemd does its thing and takes me to the login screen, HOWEVER, what is new this time is that when Antergos is starting I’m notified that the network time synchronization failed. It stops the deamon and re-attempts a few times before it seems to give up and continues on, checking everything and giving me the OK with all of the other usual startup processes. From here instead of going to the login screen as usual, i get a blinking cursor… That’s it. Dead. No amout of waiting or input on my part seems to do anything. This is true whether i select standard boot (“Antergos”) or “Antergos(fallback).” Firmware interface just takes me to BIOS where the only seeminly relevant options are to boot from hard-drive vs EFI file vs system bootloader all of which eventually take me back to the same dead end.

    Things worth mentioning that may or may not shed light on the problem:
    I’m usually pretty selective and minimalist with my package installs. I only install what I need for the most part. Therefore, I’ve never had any issue with just running full system updates via GUI or pacman -Syu. UNTIL NOW. This is the first and only time that I’ve every actively omitted any packages in my update and they were ‘tracker’ and another package that was related to ‘tracker’ I know they’re supposed to be for tracking your activities and indexing and such but I had read somewhere that they were sort of unnecessary to i figured i’d eventually get rid of them. I don’t think this was related but i could have screwed up something via dependency conflict or something like that.

    Perhaps more relevant, I don’t recall exactly, but one of the repos did update something to do with the timesyncd and i believe that libnss-systemd was also listed but i could be wrong. Since that seems to be what is broken I’m guessing something went wrong with the update.

    This might also be irrelevant but i’ll err on the side of inclusion. Daylight Savings time is a thing where i live. They just changed the time a couple days ago. I was using my machine every day just fine over the past several days but i hadn’t done a system update since maybe 4 or 5 days before that change took place.

    Working Theory so far and what I’ve tried so far

    So from what i’ve been able to piece together based on my gut and reading about related problems on other forums is that I need to login in non-graphical mode and just run the update again, hopefully fixing any errors or glitches that might have caused the problem. Alternatively most solutions seem to suggest terminal use. However, I have seemingly no way of getting to a terminal without finishing the boot process. (Hopefully this is just the naive noob in me talking and there is a way that i’m not seeing)

    Luckily I still have my old Antergos Live-USB and I had previously created separate home and root partitions on my system so i am able to sort of use my computer and access my documents by booting up via Live Usb and going to the appropriate partition. However, it seems like I can’t really do the things i did before from here unless i reinstall the OS. I’m considering doing that but I haven’t yet backed up my home partition and i’m afraid of overriding everything i have saved. (Very stupid, I know, i should have done this a long time ago) Is there a way to backup my home partition when i can only access the drive indirectly via Live-Usb? Or alternatively re-install without damaging my current setup? Ideally i would like to just fix the time sync issue or reverse the last thing that took place to restore my system to how it was and continue on with my day. However, the more i look the more into it the less i am sure that this is even possible in my situation. Unfortunately I am a bit pressed for time since I am supposed to be participating in a programming event this weekend and I have a few programming assignments coming up for a class next week. I’ll look to alternatives in the meantime but I’d really appreciate any guidance or insight you guys could give me. Anyways I’m sorry if this post go a bit lengthy the issue is not really that complex but i wanted to put everything out there just in case it was relevant.

    Thanks in advance.```

  • @kryptic_kay9 long text;)

    If you are running GNOME and uninstall tracker it is possible that you have uninstalled mostly everything you need to run GNOME… As GNOME comes as a meta package where tracker is one of deps…

    We can assist you to get it back without a reinstall…
    But a backup of personal needed files is up to you before a crash…
    We can help here too, as it is easily copy them to another drive…

  • Wow thanks for the quick response! I remembered how to get to terminal with ctrl + alt + F2. Having done so i ran a pacman -syu and updated the tracker programs. So everything should be up to date. Never Again! haha. But anyway, I’m still not able to get to the GUI login screen. I no longer get the error message regarding the time sync on boot but i don’t get any of the verbose checks verifying everything was ok like i used to either.

    I’ll try to be a little more concise but basically i’m still stuck at the blinking cursor on boot unless i login with terminal via the method stated above. It sounds like i might have messed up my gnome setup. Would you suggest i go into surgery mode and do what this guy did? (he basically suggests going through the pacman log and downgrading the recent updates one by one until i get to the root of issue)


    Or is there a simpler way fixing this?

    Thanks again!

    P.S. to be clear i never uninstalled tracker. I just omitted it from updating along with the rest of my software. Since i updated it however the problem persists. I imagine it could be due to a dependency conflict and the fact that i did something out of order?

  • @joekamprad I think i got it. Could you tell me how to mark this post as solved because honestly its very out of focus. I don’t think i immediately understood the problem properly when i made it. I was just in panic mode. Your comments however reassured me that i was on the right track and i was able to solve it.

    For anybody experiencing a similar problem, I’ll lay out the process I went through below:

    First I just made a txt file with a list of all of my packages, which i created with

    sudo pacman -Qq > packages.txt

    the second q (for quiet) is important because it restricts the output of pacman to the name of the packages only and doesn’t give you all of the extra version info. Ideally by running the script in this way your system will automatically retrieve the latest version. So now all of your packages are in one place.

    Then I built a script with vim (you can use nano, vi, or whatever other text editors are out there) named:


    that cycles through the packages i had installed in my system and reinstall them. you can get the content detailsin the link below:

    Directions for building your recovery script setup

    kudos to Shahriar Shovon for the tip!

    but one thing i should note that is that contrary to what he suggests, I would not create the recovery folder in my root directery but instead in the home directory. Why? If your system is corrupted to the point of reinstalling, you can always preserve your home directory but your root directory is going to get overwritten in 99% of cases. (100 as far as i know but you never know )

    Anyways, once the script and package.txt file are safe in your home folder, reinstall, make sure to choose your own install set up to avoid overwriting and then the process should be pretty smooth from there. When you’ve reinstalled your system, reboot, login, and THEN move your recovery folder into root if you want. otherwise, execute the script and your back to normal.

  • @joekamprad sweet thanks again

  • you are welcome ✌

boot320 unable76 failure16 sync4 Posts 7Views 318
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.