• Brand Newbie confused about building tarballs in Antergos

    Coming over from Linux Mint and I see a few stumbling blocks. I’ve not been able to find an answer anywhere to my question (I do poorly at search queries) which is:

    Antergos equivalents for things like “build-essentials”, and the missing one (?) on this list:
    apt-get build-dep gnucash # Debian based
    yum -builddep gnucash # RedHat based, but
    dnf builddep gnucash # Fedora (recent)
    zypper build-deps-install gnucash # Opensuse

    (I know I can install Gnucash the easy way, but it’s only v 3.2 and I want to reinstall v 3.3, which is way better.)

    Can somebody direct me to some how-to’s or tutorials?

    btw, have checked the man pages and am as yet unable to get pacman to do what I ask.

  • @Captain-Brillo said in Brand Newbie confused about building tarballs in Antergos:


    hopefully package in community will be updated soon:
    but it is flagged out of date till 1.10.2018…

    there is also a git version on AUR… but it fails to build here …

    Archlinux/Antergos is using makepkg to build packages from instructions getting on PKGBUILD files:
    but you can search for AUR programms also with our package manager and build it over pamac too:

    1_1541193859833_Bildschirmfoto vom 2018-11-02 22-23-40.png 0_1541193859832_Bildschirmfoto vom 2018-11-02 22-24-05.png
    or you go using a AUR helper script like yay:

  • Thanks heaps, joekamprad ☺ ☺

    Unfortunately, the material on those pages is as yet a little too much for me (but soon), so how about an example of proper pacman syntax to install a program?

    Especially the form the package is supposed to be in, like still tarballed, or extracted…
    I’ve tried everything I can think of here, obviously I’m missing something very basic

    This didn’t work:

    sudo pacman gnucash-3.3.tar.bz2

    nor did

    sudo pacman gnucash-3.3

    both giving

    error: no operation specified (use -h for help)

    And a variety of other switches.
    I hope the solution is something simple and obvious we can all get a laugh…

  • https://wiki.archlinux.org/index.php/Pacman/Rosetta

    but pacman is a package manager only and not able to build from tarballs…

    for this you will need to use makepkg or a helper like yay as i say before…

    yay is used in the same way like pacman like this:

    yay -S gnucash-git

    but to build a package from a tarball you need a PKGBUILD file with the instructions needed look here:


    this is instructing to get the source from github…
    as this it will update to 3.3.r86.g4b5ee8457 version at the moment (name say 3.0 but git holds 3.3 so it would build 3.3)

    But it fails with make[1]: *** [CMakeFiles/Makefile2:8278: gnucash/gnome-utils/CMakeFiles/gncmod-gnome-utils.dir/all] Error 2 i do not have enaugh knowlede to track this down… hopefully maintainer will update the PKGBUILD soon…

  • Thanks huge.
    I will start the learning curve…

  • you can always look intoo an flatpak if all not work, if you in need quickly

    its like, flatpak flathub org.gnucash.GnuCash

    but probably its local not system wide otherwise you must use more option ;)

    im lazy these days

  • Checking it out, ringo32, thanks muchly
    will let you know

  • Bummer. Worked great but…
    Still 3.2
    Once you’ve used 3.3, you don’t want 3.2

  • mostly on Arch-based it is for a reason if a package is not the latest… may there are some unresolved problems …

  • @Captain-Brillo
    It should be fairly easy to build it from source: https://downloads.sourceforge.net/sourceforge/gnucash/gnucash-3.3.tar.bz2
    I suppose you already read the instructions: https://wiki.gnucash.org/wiki/Building and https://wiki.gnucash.org/wiki/Building_On_Linux

    The source package has a README file that contain more instructions.
    Since the source seems to be mostly C language, you need to install a gcc compiler and make. Then you need to install packages like cmake and optionally ninja. There may be also others, but the instructions should show them.

newbie22 building4 brand2 confused2 Posts 10Views 221
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.