• Failed to start Light Display Manager


    See 'systemctl Status lightdm.service for details.
    Reached target Graphical Interface.
    Started Hostname Service.

    Please HELP! fresh Gnome Installation on Friday with latest ISO, everything went fine with no errors, a few times rebootet nothing strange noticed.

    Today i get this error.

    So please help me step by step (newbie) ho to fix this.

    What i have tried with no results:

    su
    pacman -Rncc lightdm-webkit2-greeter
    pacman -Syy lightdm-webkit-theme-antergos
    systemctl restart lightdm

    systemctl enable lightdm.service
    systemctl start lightdm.service

    sudo systemctl stop lightdm
    sudo systemctl disable lightdm
    sudo pacman -Syu lightdm lightdm-webkit2-greeter <-- confirm re-install
    sudo systemctl enable lightdm
    sudo systemctl reboot

    Thank you all in advance for any hints

  • Just try the following:

    Type the following in the terminal:
    sudo nano /etc/lightdm/lightdm.conf

    Change the following line into this:

    [LightDM]

    logind-check-graphical=true

  • @Bryanpwo

    first of all thanks, after changes in conf and reboot still get error but now i get after error following:

    Started Authorization Manager
    Started Hostname Service
    Started Modem Manager
    Reached target Multi-User System
    Reached target Graphical Interface

  • This option I should’ve mentioned earlier, sorry for that, but just change the line back into false instead of true and try to see if it is starting up with the Linux lts kernel.

  • @Bryanpwo
    Unfortunately happens same with kernel 4.14.78.1-lts and 4.18…16-arch.

  • What did you install or update before this was happening?

  • I have used pamac to install KODI and Spotify this one didnt work (package not available or something like this), and 2 GNOME plugins (Dynamic top bar and drop down terminal) and as mencioned before made some reboots and nothing strange noticied.

  • Nothing unusual indeed. I’m running out of ideas over here, maybe somebody else knows another one, but in the meantime try to install GDM and see if the system will start then.

  • @Bryanpwo

    Hurra installed gdm using:

    sudo pacman -S gdm
    sudo systemctl -f enable gdm

    reboot and voilá im able to log in.
    Do i need to change or remove something or can i leave it like this?
    Dont need to go back to lightdm but would like to understand why this happened.

  • Congrats on booting the system, you don’t have to change anything, but if you don’t want to return to lightdm then you can uninstall it.

  • @Bryanpwo
    On Pamac i see 3 lightdm items to uninstall:

    lightdm
    lightdm-webkit2-greeter
    light-locker

    Should i uninstall all 3?

  • I’m not sure about lightlocker, but you can uninstall the other two.

  • @Bryanpwo

    uninstall the the 1st two options uninstall also light-locker so im assuming is safe.

  • OK have noticed that touchpad right click (copy & paste for example) dont work anymore after install GDM, doesnt works on chrome browser or desktop, copy & paste with keyboard works.
    Touch pad worked fine with lightdm.

    xf86-input-synaptics and xf86-input-libinput are installed, if i want to uninstall xf86-input-libinput it alsos uninstall GDM.

    PS:
    Sony VAIO laptop.

  • Try rebooting and start an Xorg session. GDM starts Wayland by default and this could be a Wayland problem.

  • @Bryanpwo

    Indeed it works under xorg :) do i need to pick this option everytime i boot?

  • No, GDM remembers the last chosen option.

  • Hi, to make the touchpad work. Do the following:

    1. Install xf86-input-synaptics
    2. After installation of xf86-input-synaptics, a default configuration file is located at /usr/share/X11/xorg.conf.d/70-synaptics.conf. Copy this file to /etc/X11/xorg.conf.d/
    3. Okay, now go to the above copied location and open a terminal and type “sudoedit 70-synaptics.conf”.
    4. In the file opened using nano do the following editing:
    Section "InputClass"
        Identifier "touchpad"
        Driver "synaptics"
        MatchIsTouchpad "on"
            Option "TapButton1" "1"
            Option "TapButton2" "3"
            Option "TapButton3" "2"
            Option "VertEdgeScroll" "on"
            Option "VertTwoFingerScroll" "on"
            Option "HorizEdgeScroll" "on"
            Option "HorizTwoFingerScroll" "on"
            Option "CircularScrolling" "on"
            Option "CircScrollTrigger" "2"
            Option "EmulateTwoFingerMinZ" "40"
            Option "EmulateTwoFingerMinW" "8"
            Option "CoastingSpeed" "0"
            Option "FingerLow" "30"
            Option "FingerHigh" "50"
            Option "MaxTapTime" "125"
            ...
    EndSection
    

    Don’t exactly copy the code as it is and paste it. If I remember, the first four lines are there already and you need to add the remaining lines from the above code and remove the existing part of that section only.

    Once you do this (Ctrl+0) to save and (Ctrl+X) to exit.

    Reboot.
    I am certain that it will work now. I had the same problem after the installation of Manjaro Linux. This was what I did and it worked perfectly afterwards. I got the above mentioned info from the Arch Wiki, it is really nice and well documented. I never thought that Wiki writers would have the same problem as me. Well I guess everybody has the same problems in rolling distros like Arch and it’s derivatives.

    If you have any further doubts, refer to the following link.

    https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Installation

  • @bangsergio may the GNOME extensions are the problem for starting session with lightdm.
    if you install them with package manager you can try uninstall them, or remove them from users directory so that they do not auto start again:

    they are located here:

    cd .local/share/gnome-shell/extensions/
    rm -R name-of-the-folder-from-extension-to-remove

manager80 display59 light20 Posts 19Views 830
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.