• Headphones tinny when left/right balanced

    Hi all,
    I’ve had an ongoing issue with my laptop for the last year or so. When I have headphones plugged in, if the left/right is balanced even, it is really difficult to hear and the sound is very tinny (high in treble, hard to make out, almost static-y). If I lower either the left or right channel, it normalizes more. It doesn’t actually change the left/right balance any, just the quality of the sound (almost like it’s trying to change between a front/back channel). I’ve tried hdajackretask to set the port as “Headphones” by default, but it doesn’t make a difference.

    This is a Sager NP8153, with “Intel Corporation Sunrise Point-H HD Audio.”

    I actually have two ports (three including digital), the one I’m having to use is considered a line port. What Windows considers the headphone port doesn’t work. Here’s some imformation:


    $ lspci
    00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 07)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16) (rev 07)
    00:14.0 USB controller: Intel Corporation Sunrise Point-H USB 3.0 xHCI Controller (rev 31)
    00:16.0 Communication controller: Intel Corporation Sunrise Point-H CSME HECI #1 (rev 31)
    00:17.0 SATA controller: Intel Corporation Sunrise Point-H SATA Controller [AHCI mode] (rev 31)
    00:1c.0 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #1 (rev f1)
    00:1c.4 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #5 (rev f1)
    00:1c.6 PCI bridge: Intel Corporation Sunrise Point-H PCI Express Root Port #7 (rev f1)
    00:1f.0 ISA bridge: Intel Corporation Sunrise Point-H LPC Controller (rev 31)
    00:1f.2 Memory controller: Intel Corporation Sunrise Point-H PMC (rev 31)
    00:1f.3 Audio device: Intel Corporation Sunrise Point-H HD Audio (rev 31)
    00:1f.4 SMBus: Intel Corporation Sunrise Point-H SMBus (rev 31)
    01:00.0 VGA compatible controller: NVIDIA Corporation GP104M [GeForce GTX 1070 Mobile] (rev a1)
    6d:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTL8411B PCI Express Card Reader (rev 01)
    6d:00.1 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 12)
    6e:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)
    $ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC898 Analog [ALC898 Analog]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 1: ALC898 Digital [ALC898 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    $ pacmd list-sinks
    1 sink(s) available.
      * index: 0
    	name: <alsa_output.pci-0000_00_1f.3.analog-stereo>
    	driver: <module-alsa-card.c>
    	state: IDLE
    	suspend cause: (none)
    	priority: 9039
    	volume: front-left: 99957 / 153% / 11.00 dB,   front-right: 8517 /  13% / -53.17 dB
    	        balance -0.91
    	base volume: 65536 / 100% / 0.00 dB
    	volume steps: 65537
    	muted: no
    	current latency: 40.31 ms
    	max request: 6 KiB
    	max rewind: 6 KiB
    	monitor source: 0
    	sample spec: s16le 2ch 44100Hz
    	channel map: front-left,front-right
    	used by: 0
    	linked by: 1
    	configured latency: 40.00 ms; range is 0.50 .. 2000.00 ms
    	card: 0 <alsa_card.pci-0000_00_1f.3>
    	module: 6
    		alsa.resolution_bits = "16"
    		device.api = "alsa"
    		device.class = "sound"
    		alsa.class = "generic"
    		alsa.subclass = "generic-mix"
    		alsa.name = "ALC898 Analog"
    		alsa.id = "ALC898 Analog"
    		alsa.subdevice = "0"
    		alsa.subdevice_name = "subdevice #0"
    		alsa.device = "0"
    		alsa.card = "0"
    		alsa.card_name = "HDA Intel PCH"
    		alsa.long_card_name = "HDA Intel PCH at 0x2ffff20000 irq 126"
    		alsa.driver_name = "snd_hda_intel"
    		device.bus_path = "pci-0000:00:1f.3"
    		sysfs.path = "/devices/pci0000:00/0000:00:1f.3/sound/card0"
    		device.bus = "pci"
    		device.vendor.id = "8086"
    		device.vendor.name = "Intel Corporation"
    		device.product.id = "a170"
    		device.product.name = "Sunrise Point-H HD Audio"
    		device.form_factor = "internal"
    		device.string = "front:0"
    		device.buffering.buffer_size = "352800"
    		device.buffering.fragment_size = "176400"
    		device.access_mode = "mmap+timer"
    		device.profile.name = "analog-stereo"
    		device.profile.description = "Analog Stereo"
    		device.description = "Built-in Audio Analog Stereo"
    		alsa.mixer_name = "Realtek ALC898"
    		alsa.components = "HDA:10ec0899,15586a02,00100003"
    		module-udev-detect.discovered = "1"
    		device.icon_name = "audio-card-pci"
    		analog-output-speaker: Speakers (priority 10000, latency offset 0 usec, available: no)
    				device.icon_name = "audio-speakers"
    		analog-output-headphones: Headphones (priority 9000, latency offset 0 usec, available: yes)
    				device.icon_name = "audio-headphones"
    	active port: <analog-output-headphones>
  • Have you tried to restore alsa? It looks like something messed up the settings, since the decibel levels between left and right differ a lot.

  • Thanks, didn’t seem to help. The difference in decibels was probably me, since if they’re both even I can’t really hear anything. I have to turn one side way down to be able to hear anything. In pavucontrol, if I start one side down and one side at 100%, as I slide the one that’s down back up, it actually gets quieter

  • I’m sorry to hear that, I don’t have any fresh idea on this, but maybe somene else has. (Hence the answering this post to bump it up again😉 )

  • has it ever been working correctly?
    can you confirm the error with a different pair of headphones?
    if one port does not work at all and with all that “quiet makes it more listenable”, it sounds like a hardware wiring issue, like if the outgoing signal of line and headphones somewhat is short-circuited.

  • It has worked correctly, before about a year ago. And it continues to work fine in windows (really, both ports work fine in windows if I set the one to line out instead of rear out for surround sound) which makes me think it isn’t a hardware issue.

    I’ve actually seen other people suggest the same solution before on stack overflow to lower the left or right channel, but never saw an actual solution to the root issue or any idea what it was.

  • These links might be helpful to you.
    Terrarium TV Apk iTube APK WMI Provider Host free robux

headphones8 leftright4 tinny1 balanced1 Posts 8Views 294
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.