• No network devices available after install


    Hi

    I have just installed Antergos and can’t connect to my WIFI. During the installation I had no problems connecting from the Live USB. The system tray shows that there are no network devices availiable:

    0_1540664802649_58dc5e9e-9b67-4f88-babb-5684b55cb665-image.png

    I then ran the ip link command an the only interface that it outputs is the loopback interface:

    0_1540665215381_a729e987-f5b5-4b52-9cb8-6dd66e9e9ed6-image.png

    The lspci -k command gave the following output:

    0_1540665565396_5f990c31-0626-4b60-9bd7-236e3e7ce7e4-image.png

    So the network card is recognised and the drivers are installed and in use. I am confused as to why the network interface does not show up and what to do to be able to connect to the Wifi.

    Any help would be much appreciated.

  • @dimax25 Bro, I experienced the same problem in installing Wifi drivers but mine is Broadcom BCM 43142 model.

    I suggest you to install linux-headers package from Pamac/terminal first. This is like one of the fundamental required packages. I don’t know if it already preinstalled or not, but just check it. Once you do this, you can get on with your debugging.

    I spent over 3 hours just to get my Wifi right, but after that everything is a breeze.
    Sorry, I wish I knew more about this but I don’t. Anyway, try this and hope this will be helpful.

  • @Quantum_Sniper Thanks for the suggestion. Unfortunately it didn’t change anything. ☹

    I used arch-chroot from the live USB to install the package but the problem persists…

  • @dimax25 i would say it can be different issues:

    • firmware not loaded correctly or unaviable
    • driver do not support device or needs a newer version.
    • latest kernel have a problem with detecting the device right

    check:
    dmesg | grep ath10k
    to see what is gouing wrong on device initalisation

    Try booting LTS kernel:

    sudo pacman -S linux-lts linux-lts-headers
    sudo mkinitcpio -P
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    and remind to choose LTS kernel on bootmenu by go to Advanced options for Antergos and choose it!

  • @joekamprad booting the LTS kernel unfortunately did not fix the problem.

    The output of

    dmesg | grep ath10k
    

    Is the following:

    0_1540734418118_8a511c4c-29e2-4b92-929c-4e5e92867873-image.png

    So it appears that the firmware didn’t load correctly but I still don’t know how to interpret this and how to fix it.

    I have tried to unload and load the module manually by using

    modprobe -r ath10k
    

    and then

    modprobe ath10k
    

    But that did not help either. Thank you for taking the time to help.

  • /usr/lib/firmware/ath10k/QCA9377/hw1.0/board-2.bin
    /usr/lib/firmware/ath10k/QCA9377/hw1.0/board.bin
    /usr/lib/firmware/ath10k/QCA9377/hw1.0/firmware-5.bin
    /usr/lib/firmware/ath10k/QCA9377/hw1.0/firmware-6.bin
    /usr/lib/firmware/ath10k/QCA9377/hw1.0/notice_ath10k_firmware-5.txt
    /usr/lib/firmware/ath10k/QCA9377/hw1.0/notice_ath10k_firmware-6.txt
    

    firmware is included inside linux-firmware …

    I would try LTS kernel

wifi151 wireless38 network15 Posts 6Views 282
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.