• Keyboard Shortcut Key not working in Antergos MATE


    Hello guys. I installed Antergos MATE just now. The main reason why I love MATE DE is because of it’s shortcut keys customization and the low resource needs of it.

    Okay, so here’s the problem. A lot of my shortcut keys combo makes use of Windows superkey (logo) . But when I press windows key, it just opens the Start Menu (Antergos Menu) and does not perform it’s shortcut function. For example, (Windows+D) shows the desktop immediately, (Windows+L) for lockscreen, (Windows+ <—/–>) for tiling screens to the left/right side of screen and so on. A lot of my shortcuts are not working because the system just opens the Menu.

    Any suggestions?

    (Note: I am coming from Debian Stable 9.5 MATE where it used to work perfectly but got pissed at Debian at it’s very OLD software packages when “youtube-dl” command didn’t work and it uses Firefox ESR which is even more irritating. Hence I am back to Antergos except that I chose MATE this time around.)

  • Anybody, any ideas?

  • may related to exactly that we are using more new versions and they changed that on MATE development (upstream) or Debian was changing this different from source settings from MATE development…

    I can have a look at your issue, but i need to setup a VM first do not have a MATE one jet ;)

  • @joekamprad Thanks for looking into the issue. ☺

    Some update. I tried to solve this issue how much ever I could. I opened Keyboard Preferences—>Accessibility—>And here I unchecked “Disable sticky keys if two keys are pressed together” option and checked the option “Simulate simultaneous keypresses”. Well this solved the issue to some extent but the problem still exists. Now I have to press 2-3 times with the right timing to make the shortcuts work. The shortcut never works the first time, it works the second time. But it is still irritating to press it twice to make it work.

    Debian uses 1.16 MATE currently in Debian Stable MATE while Antergos uses 1.20. Maybe some upstream changes as you said. Can you look into this when you have some free time?

  • i will if i get a Antergos Mate installed … fails at the moment caused by a package dependency problem…

  • if i understand you right …

    the whisker menu (Antergos menu) have its own settings for a shortcut, if i change this to m i can use windows key for shortcuts:

    0_1541087355457_Bildschirmfoto vom 2018-11-01 16-45-10.png
    right-click on the menz button and open up preferences…

  • @joekamprad Wow, sir! You are simply brilliant.

    You nailed it!! It works perfectly now.

    I spent a lot of time to try to solve it. Never tried right-clicking the menu.
    👍 👏 👌

  • @joekamprad said in Keyboard Shortcut Key not working in Antergos MATE:

    if i understand you right …

    the whisker menu (Antergos menu) have its own settings for a shortcut, if i change this to m i can use windows key for shortcuts:

    This works. But every time ‘m’ is pressed it opens the menu. So I have changed it to one of the keys which I use the least on the keyboard. Just as a note to anybody who faces this issue in the future. Works well 👍

    0_1541087355457_Bildschirmfoto vom 2018-11-01 16-45-10.png
    right-click on the menz button and open up preferences…

  • yes sure the m was only to test it… better choose a 2 key combo ;)

keyboard75 mate67 key26 shortcut12 Posts 9Views 321
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.