Hello, I have weird issue. Yesteday I ran update (-Syy & then -Syu)
Downloaded things just fine, but when installing, it gave me lots of errors about missing space. I ignored that, because I am an idiot and also because partition was showing 60GB free space. After the update done. I run those two commands again to be sure everything will be okay and it said “nothing to do”. Also it said that I should reboot because something system-y was changed/updated. (sorry, can’t quite recall, it was late night (early morning actually) and the notification was there only about 3 seconds and all I wanted was to finish my work, update system and go to sleep).

So, after restarting, I couldn’t boot. After loading bootloader, it said

: : Running Hook [udev]
: : Triggering uevents...done.
waiting 10 seconds for device /dev/sda1.....
ERROR: device '/dev/sda1' not found. Skipping fsck.
ERROR: Unable to find root device '/dev/sda1'.
You are being dropped to a recovery shell
  Type 'exit' to try and continue booting
sh: can't access tty: job control turned off
[rootfs /]#

booting to fallback kernel gets same error.

My disk is:
/dev/sda1 - Antergos (own boot folder, own home folder)
/dev/sda2 - swap (shared with sda1 antergos and sda2 antergos)
/dev/sda3 - Different Antergos (again, separate OS with own boot folder, own home folder)

now I am booted to sda3 antergos which is now running okay. But before today, it get same error, because I tried to open 8GB txt file from sda1 partition. It opened with libreoffice. Then froze my OS so I rebooted (normally thru system icon). Then it gave me same error with “unable to find /dev/sda3” I booted live USB and performed “fsck -f /dev/sda3” it fixed some trees and then after reboot, system is working.

I did the fsck thing with /dev/sda1 also fixed some trees, but it didn’t help. Won’t boot, but I can access sda1 from sda3 or live USB.

I am using syslinux as a bootloader.

So far I tried:

  • performing fsck - can’t boot
  • checked UUID’s in fstab - matching - still can’t boot
  • written file on sda1 - file written - still can’t boot
  • reinstalled linux, linux-lts, linux-headers - still can’t boot
  • tried to chroot and run mkinitcpio -p linux - still can’t boot (see output below)

outputs:

/etc/fstab (on /dev/sda1):

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
#
UUID=ffc91340-eb6c-4778-8d79-1fd446bf7450 / ext4 defaults,relatime,data=ordered$
UUID=b36809c3-9d80-430c-ab72-87c169c4119b swap swap defaults 0 0

blkid:

# blkid
/dev/sda1: LABEL="primary" UUID="ffc91340-eb6c-4778-8d79-1fd446bf7450" TYPE="ext4" PARTLABEL="prim" PARTUUID="613c8675-94e0-4297-902e-7d69bdf6e9d1"
/dev/sda2: UUID="b36809c3-9d80-430c-ab72-87c169c4119b" TYPE="swap" PARTLABEL="swap" PARTUUID="ec9832af-a39d-481b-8671-93912624a80d"
/dev/sda3: LABEL="sec" UUID="df7397e9-f9aa-4247-b5da-2548f46de698" TYPE="ext4" PARTLABEL="sec" PARTUUID="1318e7a4-74b1-4441-afa4-692d83c986a9"

mkinitcpio -p linux:

$ sudo mount /dev/sda1 /mnt
$ sudo mount -t proc none /mnt/proc
$ sudo mount -t sysfs none /mnt/sys
$ sudo mount --bind /dev /mnt/dev
$ sudo chroot /mnt
# sudo mkinitcpio -p linux
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 4.18.16-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 4.18.16-arch1-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: aic94xx
==> WARNING: Possibly missing firmware for module: wd719x
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful

(warnings about missing firmware always was there, so I don’t think it’s relevant)

sudo uname -r && pacman -Q linux:

# sudo uname -r && pacman -Q linux
4.17.13-arch1-1-ARCH
linux 4.18.16.arch1-1

# sudo uname -r && pacman -Q linux-lts
4.17.13-arch1-1-ARCH
linux-lts 4.14.78-1

I am begginer with linux so please, if you have any suggestions, I will try it, but I am afraid, I will need your guidance with it (steps how to do it)

any suggestions? I think the problem is different kernel version with linux version, but don’t know how to fix it.

//EDIT: Also in /dev/sda1 there is:
/boot/syslinux
and also inside /boot folder is another /boot folder:
/boot/boot/syslinux

When booting, bootloader is showing options from /boot/boot/syslinux/syslinux.cfg so maybe if we can “tell him” to boot from /boot/syslinux/syslinux.cfg? Don’t know how to do that :(.