• New dual boot installation just boots to Win10

    I tried installing Antergos from usb. The installation went fine, but when I rebooted, I didn’t get the Grub menu. It just booted straight to Windows. 2 quick notes: I disabled secure boot, but left UEFI intact. That is, I did NOT switch to legacy. Also, I didn’t disable fast start until AFTER the Antergos was installed. I should have done this before, but I forgot about it.

    I bought this machine yesterday. It is an Acer Aspire ES 15 with a 1TB HD. I shrank this leaving about 250 GB for the Windows 10.

    On the machine that this new machine is replacing, I had installed Antergos and had basically the same problem. However, I subsequently successfully installed Xubuntu after the Antergos, I had problems getting the Xubuntu to boot to the Grub menu instead of Windows, but after a lot of research, I got it to work by running the following command in Windows: bcdedit /set ‘{bootmgr}’ path \EFI\ubuntu\grubx64.efi

    In the Antergos forum I’ve seen mention of doing something like this (run bcdedit), but it seemed that it didn’t really work for whoever did it.

    After doing the bcdedit, I got the grub menu on boot and it showed the Antergos installation, so I was able to use the Antergos. But now I only want Antergos on this machine with the Windows 10, só using the Ubuntu grub isn’t an option.

    What should I do to get this to boot to the grub menu?

  • @arpeasal
    You should get it working the same way as you did with Ubuntu (assuming you installed Antergos in the right boot mode, i.e. UEFI). The path to Antergos grubx64.efi just needs to be correct. It should be something like


    but you should be able to find the path with the file manager in Windows or either Linux.

  • Thanks, Manuel.

    I followed the directions below, which I found at:

    Right click on the start button and choose administrator command prompt
    Type mountvol g: /s (This maps your EFI folder structure to the G drive).
    Type cd g:\EFI
    Type dir g:\EFI.
    The result of the last commands was to show a table:
    Diretório: g:\EFI

    Mode LastWriteTime Length Name

    d----- 25/10/2018 18:30 antergos_grub
    d----- 09/01/2018 09:37 Microsoft
    d----- 09/01/2018 09:37 Boot
    d----- 09/01/2018 11:36 OEM

    I then issued these 2 commands:
    PS g:\EFI> cd boot
    PS g:\EFI\boot> dir

    The result was:
    Diretório: g:\EFI\boot

    Mode LastWriteTime Length Name

    -a---- 30/08/2018 02:02 1225656 bootx64.efi

    I then changed to the antergos_grub directory:
    PS g:\EFI> cd antergos_grub
    PS g:\EFI\antergos_grub> dir

    The result was:
    Diretório: g:\EFI\antergos_grub

    Mode LastWriteTime Length Name

    -a---- 25/10/2018 18:30 122880 grubx64.efi

    So, should my command be:
    bcdedit /set {bootmgr} path \EFI\antergos_grub\grubx64.efi

  • So I tried this command:

    bcdedit /set {bootmgr} path \EFI\antergos_grub\grubx64.efi

    and got an error message. I looked at my notes from the last time and found that Windows now requires single quotes around {bootmgr}.

    The command:

    bcdedit /set '{bootmgr}' path \EFI\antergos_grub\grubx64.efi

    worked fine. But the boot menu didn’t include Windows.

    After I did a little research, I ran these two commands:

    sudo os-prober
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    I then rebooted and the Windows was now in the Grub menu.

    So the problem is solved. But I don’t see how to mark this post as solved.

installation326 boot320 dual40 boots13 Posts 5Views 417
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.