• Unable to boot after kernel update 4.18.16


    On my machine (Asus F553M) system didn’t boot after kernel update to 4.18.16. So I had to boot into a live usb and make a kernel downgrade to 4.18.14. via arch-root. After that the system boots again. Anyone else having trouble with that?

  • @schuenne said in Unable to boot after kernel update 4.18.16:

    Asus F553M

    do you try using LTS Kernel?

  • I haven’t tried so far. But I am thinking about it. Can I just install it via
    pacman -S linux-lts
    and update the bootlaoder?
    Also: I don’t have grub installed as a bootloader since this didn’t work when installing and booting afterwards. How do I update ‘the other bootloader’ ?

  • sudo bootctl update
    
  • Thanks.
    So after installing the LTS kernel and updating the bootloader will I be able to switch between kernels manually in bootloader menu or is it going to be LTS from there on automatically?

  • after command above you can follow with sudo mkinitcpio -P

  • as @ringo32 said in Unable to boot after kernel update 4.18.16:

    mkinitcpio -P

    https://manned.org/mkinitcpio.8

    -P, --allpresets
    Process all presets contained in /etc/mkinitcpio.d. See the -p option
    for more detail about presets.

    • to generate it for all installed kernels

    -p, --preset preset
    Build initramfs image(s) according to specified preset. This may be a
    file in /etc/mkinitcpio.d (without the .preset extension) or a full,
    absolute path to a file. This option may be specified multiple times
    to process multiple presets.

    • needs kernel names to generate for specific ones like:
      sudo mkinitcpio -p linux-lts
  • @joekamprad After installing the lts-kernel and updating the bootlaoder via
    sudo booctl update
    I created the initial ramdisk envirement via
    sudo mkinitcpio -p linux-lts
    as you mentioned above. But after this it seems that I still run on 4.18.14. At least this is what
    uname -r
    is tells me.
    In the boot menu I can only choose bewteen Antergos and Antergos fallback. It seems like the fallback version isn’t working at all because it gives me an error and then the ‘normal’ kernel gets loaded.
    Another question: If I try to update packages vie pamac and unselect the 4.18.16. kernel it always gets installed anyway. Why is this and how can I stop my system (pamac?) from doing so?

  • what gives: sudo bootctl list ?
    is the command sudo bootctl update givin any error?

    to avoid updating a package you must put it to ignore list.
    Can be done inside pamac or inside /etc/pacman.conf file.
    0_1541013186460_Bildschirmfoto vom 2018-10-31 20-12-48.png

  • @joekamprad sudo bootctl list gives me:

    Available boot entries:

        title: Antergos (default)
        linux: /vmlinuz-linux
       initrd: /intel-ucode.img /initramfs-linux.img
      options: root=UUID=cbc12066-e4c8-47cb-88e1-91b6e3d3514a resume=UUID=6f160fc4-efae-4b16-8b68-835c71cadf59 rw
    
        title: Antergos (fallback)
        linux: /vmlinuz-linux
       initrd: /intel-ucode.img /initramfs-linux-fallback.img
      options: root=UUID=cbc12066-e4c8-47cb-88e1-91b6e3d3514a rw quiet
    

    sudo bootctl update returns:

    Copied “/usr/lib/systemd/boot/efi/systemd-bootx64.efi” to “/boot/EFI/systemd/systemd-bootx64.efi”.
    Copied “/usr/lib/systemd/boot/efi/systemd-bootx64.efi” to “/boot/EFI/BOOT/BOOTX64.EFI”.
    Failed to create EFI Boot variable entry: Input/output error

    For now I might just avoid to update linux via entry in pamac as you kindly mentioned in your last post.

  • @schuenne said in Unable to boot after kernel update 4.18.16:

    bootctl

    as far as i understand you will need to add an entry for the linux-lts manually:

    https://wiki.archlinux.org/index.php/systemd-boot#Adding_loaders

  • Puh, to be honest, I am getting a bit tired of using arch linux. After the latest update I am not able to see my desktop at all. I can get into the login screen and type in my password. But after that I can only see the cursor an a black screen with nothing more. Tried to downgrade several packages (xorg, gnome-desktop, …) but nothing worked for me so far. I don’t know what to do anymore.

  • @schuenne downgrading will mostly cause more problems then solving them (dependency issues) and not so much users go for systemdboot at all so help is a bit complicated, your hardware should not make much problems (intel CPU and GPU)

    If you want help we will do our best.

  • @joekamprad Thanks for your help! I haven’t had any issues since the upgrade to kernel 4.18.16. As mentioned in here I had to downgrade via live-usb and chroot to kernel 4.18.14 to make the system boot again. After that it worked fine again. I don’t know what of the november upgrades is causing the error. As mentioned above. I am able to log in but after that I can only see a black screen with my white arrow. The trackpad is working as I can move the arrow arround. What further information would you need, to apply some help?

  • @joekamprad O.K. I am back with a working system. Luckily with timeshift and a live-usb I was able to restore my system from last week. After that I did all the upgrades besides the linux-kernel upgrade and now it works. It might just be that one or more packages were corrupted during the last install? I have no idea. But till then I will just stay away from any further kernel upgrades by ignoring it through pamac as you mentioned in your post above.

  • this will be only a short time solving, as much other packages needs to be builded against kernel.

    caus of this i was sayuíng that LTS kernel is the best option.

  • @joekamprad OK. I understand. So in order to add an entry for the linux-lts manually:
    Arch wiki says that each file must contain one entry. This would mean I would have to make a new entry in the /boot/loader/entries directory called antergos-lts.conf for example, right? But where do I find the information for the entries? My current antergos.conf file looks like this:

    title Antergos
    linux /vmlinuz-linux
    initrd /intel-ucode.img
    initrd /initramfs-linux.img
    options root=UUID=cbc12066-e4c8-47cb-88e1-91b6e3d3514a resume=UUID=6f160fc4-efae-4b16-8b68-835c71cadf59 rw

    I guess I can choose the title myself. But what do I need to pass in for linux, initrd (why are there two entries for this anyway?) and options?

    ls -lha of the /boot directory gives:

    drwxr-xr-x 4 root root 1,0K 4. Nov 16:18 .
    drwxr-xr-x 19 root root 4,0K 2. Sep 14:42 …
    drwxr-xr-x 4 root root 512 2. Jun 21:59 EFI
    -rwxr-xr-x 1 root root 29M 4. Nov 16:23 initramfs-linux-fallback.img
    -rwxr-xr-x 1 root root 7,8M 4. Nov 16:23 initramfs-linux.img
    -rwxr-xr-x 1 root root 28M 4. Nov 16:23 initramfs-linux-lts-fallback.img
    -rwxr-xr-x 1 root root 8,0M 4. Nov 16:22 initramfs-linux-lts.img
    -rwxr-xr-x 1 root root 1,7M 25. Aug 10:35 intel-ucode.img
    drwxr-xr-x 3 root root 512 2. Jun 21:59 loader
    -rwxr-xr-x 1 root root 5,6M 13. Okt 15:41 vmlinuz-linux
    -rwxr-xr-x 1 root root 4,6M 21. Okt 13:39 vmlinuz-linux-lts

    I really appreciate you helping me out.

  • I guess the options for root and resume are the IDs for the root and the swap partitions, so they should stay the same as in the antergos.conf file, right?

  • Seems like I managed to get the entry for the LTS kernel. Now
    sudo bootcl list gives me:

    Available boot entries:

        title: Antergos (default)
        linux: /vmlinuz-linux
       initrd: /intel-ucode.img /initramfs-linux.img
      options: root=UUID=cbc12066-e4c8-47cb-88e1-91b6e3d3514a resume=UUID=6f160fc4-efae-4b16-8b68-835c71cadf59 rw
    
        title: Antergos (fallback)
        linux: /vmlinuz-linux
       initrd: /intel-ucode.img /initramfs-linux-fallback.img
      options: root=UUID=cbc12066-e4c8-47cb-88e1-91b6e3d3514a rw quiet
    
        title: Antergos-LTS
        linux: /vmlinuz-linux-lts
       initrd: /intel-ucode.img /initramfs-linux-lts.img
      options: root=UUID=cbc12066-e4c8-47cb-88e1-91b6e3d3514a resume=UUID=6f160fc4-efae-4b16-8b68-835c71cadf59 rw
    

    My antergos-lts.conf file in the /boot/loaders/entries/ looks like this:

    title Antergos-LTS
    linux /vmlinuz-linux-lts
    initrd /intel-ucode.img
    initrd /initramfs-linux-lts.img
    options root=UUID=cbc12066-e4c8-47cb-88e1-91b6e3d3514a resume=UUID=6f160fc4-efae-4b16-8b68-835c71cadf59 rw

    When booting up the system I get the possibility to choose Antergos-LTS now. But booting up gives the same error as when using the 4.18.16 kernel:
    0_1541349313698_boot.png

boot271 kernel125 unable70 4.18.161 Posts 19Views 470
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.