• Fresh install "error: file '/boot/vmlinuz-linux' no found"


    I currently dual boot with Win10. I started 3 years ago with Debian, then added Manjaro, Mint and some other distros that might interest me. when new distro takes charge of grub menu, I put Manjaro back in charge as it won’t run otherwise. So far so good. Yesterday, I decided I would like to try Antergos so downloaded latest “antergos-18.10-x86_64.iso”

    When I booted the LiveUSB, it offered a text message to reboot again, and chose Antergos Live (that’s what I did chose), but message went away after a minute, and booted into desktop OK. Installation all went well, but at the end, I received message “Antergos Installer -Confirmation” with IMPORTANT information saying there may have been a problem with the bootloader installation etc…
    (see pic below for full details)

    https://i.imgur.com/xLxU76o.jpg

    I clicked OK and installation said completed ok.

    When I try to boot into Antergos, I get boot error…

    error: no such device
    error: file ‘/boot/vmlinuz-linux’ no found etc…
    (see pic below for full details)

    https://i.imgur.com/feRdz22.jpg

    So to try to fix this I booted LiveUSB and put Manjaro back in charge of grub (as I have done before) then boot Manjaro and ran update-grub, hoping this would fix things.

    Reboot and I can see Antergos in grub menu but still can’t boot, get error…
    ERROR : resume : no device specified for hibernation… etc
    (see pic below for full details)

    https://i.imgur.com/d5GVukb.jpg

    I have installed Linux distros lots of times in the past and try to fix any problems myself if I can. But I’m still a bit of a novice and I am stuck for a solution. Any help/advice would be appreciated.

    The details of the computer are…

    Legacy BIOS Mode MBR Partition style
    ASUS Eee Box EB1501P - Legacy BIOS Mode MBR Partition style
    CPU: Dual core Intel Atom D525 1795 MHz
    Graphics Card: NVIDIA GT218 [ION]
    Audio Card-1 Intel NM10/ICH7
    RAM: 4GB DDR2 SODIMM 800 MHz
    Network Card-1: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express)
    Network Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
    SSD: 240 GB

    I tried to fix by boot using a LiveUSB and mount the Antergos partition and run update-grub but getting errors.

    $ sudo mount /dev/sda16 /mnt
    $ sudo grub-install --boot-directory=mnt/boot /dev/sda
    Installing for i386-pc platform.
    grub-install: error: failed to get canonical path of `overlay'.
    $ 
    
    $ sudo update-grub
    /usr/bin/grub-probe: error: failed to get canonical path of `overlay'.
    $ sudo grub-mkconfig -o /boot/grub/grub.cfg
    /usr/bin/grub-probe: error: failed to get canonical path of `overlay'.
    $
    

    any help would be appreciated

    EDIT: sorry about the links not working, I have change to imgur, hope new links work.

  • https://antergos.com/wiki/miscellaneous/how-to-fix-grub-with-bios-boot/

    Is how you should repair grub on a BIOS/legacy system.

    … the links to the pictures you give are not aviable…

  • thanks for quick response, I tried to boot the LiveUSB again but it fails to boot, just selected Antergos Live from menu and it hangs with the antergos logo and 3 or 4 dots beneath, and doesn’t move from there.

    So I rebooted and removed…
    quiet splash and selected language country screensize etc then selected the first option Antegos Live from boot menu and got this message on screen…

    : : running early hook [udev]
    : : ruuning early hook [plynouth]
    : : running hook udevl
    : : triggering uevents...
    : : running hook [plynouth]
    : : running hook [memdisk]
    : : running hook [archiso]
    : : running hook [archiso_loop_mnt]
    : : Mounting '/dev/disk/by-label/ANTERGOS' to '/run/archiso/bootmnt'
    : : Device '/dev/disk/by-label/ANTERGOS' mounted successfully
    : : Mounting /run/archiso/cowspace (tmpfs) filesystem, size=320M...
    losetup: /run/archiso/bootmnt/arch/root-image.sfs: failed to setup boot device: No such file or directory
    : : Mounting ' ' to '/run/archiso/sfs/root-image'
    Waiting 30 seconds for device
    ERROR: ' ' device did not show up after 30 seconds...
    Falling back to interactive prompt
    You can try to fix the problen manually, log out when you are finished
    sh: can't access tty: Job control turned off
    [rootfs ] #
    
    I don't have the knowledge to figure out what is wrong, have you seen this before?
    
    I don't have the knowledge to figure out what is wrong, have you seen this before?
    
  • @fracmo2000 I do not know what wents wrong on booting liveISO again… but i am quiet sure that you srewed up grub by installing it the wrong way, so the only way is to reinstall grub-loader after arch-chroot into installed system from liveISO as it is written in the wiki entry.

error339 fresh43 Posts 4Views 1226
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.