• Invalid or corrupted database -- Antergos Linux


    Hello

    I’m not a complete Linux user, but still consider myself a novice.

    I’m tyring to update Antergos Linux (all of the updates) and get the following error:

    Synchronizing package databases…
    Refreshing antergos.db…
    Starting full system upgrade…

    Failed to prepare transaction:
    invalid or corrupted database

    I’ve tried updating/refreshing keys with no luck. Restarted the computer, et cetera.

    I installed Antergos about a month ago and have been fine-tuning it to my liking. So far, it’s been going good.

    But I can’t update packagase or download new ones. Please advise. Thanks!

    -Andre

    code_text
    
  • can you give out put directly in <code> off sudo pacman -Syy
    ?

  • @ringo32 Hi. Sorry for the severe delay in response. It’s been a hectic week. Here’s what I get when typing the command you gave me:
    :: Synchronizing package databases…
    antergos 167.4 KiB 2.92M/s 00:00 [######################] 100%
    error: failed to update core (no servers configured for repository)
    error: failed to update extra (no servers configured for repository)
    error: failed to update community (no servers configured for repository)

    And here’s what I get when I update via the software update in Cinnamon:
    Synchronizing package databases…
    Refreshing antergos.db…
    Starting full system upgrade…

    Failed to prepare transaction:
    invalid or corrupted database

    I have tried replacing the pacman.conf file and then regenerating the keys with no luck.

    Thanks.

    -Andre

    error: failed to update multilib (no servers configured for repository)
    error: failed to synchronize all databases

  • @ringo32 I’ve also tried to uncomment the necessary mirrors in the antergos-mirrorlist file. I’m wondering if my main pacman.conf file is not pointing to that file?

    -Andre

  • Im curius are you behind an DNS or is your IP settings changed ? but your antergos-mirrorlist seems ok? but de mirrorlist regular one seems the issue , thats a seporated list… Also tried reflector to genererate a new arch list?

  • @ringo32 I did end up solving the issue. Apparently, and I don’t know how this happened, but there were NO servers configured. It’s really odd because I was able to update up until about a week ago. Anyway, I updated some of the necessary files as spelled out in the pacman.conf file, refreshed the keys, and now it all works.

    Thanks!

invalid19 database14 corrupted13 Posts 6Views 403
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.