• auto opening and how to use wallet properly


    Ive read how to open wallet on login but that doesnt seem to work. Supposedly when its called kdewallet and uses the same unlock password as your username password, it should automatically unlock, but it doesnt.

    Second thing I cant figure out is how to load ssh key passphrases and use ssh-agent & ssh-add properly.

    I have set SSH_ASKPASS="/usr/bin/ksshaskpass", that location is correct and I can run it manually using that full path.

    I can run eval ssh-agent and it will come back with an agent PID. I can run ssh-add some-file and it will ask for the passphrase on the command prompt, it doesnt popup the ksshaskpass dialog.

    Ultimately, what I like to accomplish is to have my passphrases in kwallet and my keys loaded when I login and unlock the wallet.

    If anyone knows how to fix these things i will be a happy man. Thanks!

    ps whats up with all the bullshit smileys using '`'" ?? I cant use proper quotes and ticks without that silly smiley poppin' up all over the place.
    
  • @injo you will have to use SDDM as the login manager, see https://wiki.archlinux.org/index.php/KDE_Wallet#Unlock_KDE_Wallet_automatically_on_login
    These instructions worked for me.
    I do not use ssh key passphrases so I have no advice on how to fix that.

  • Thanks for the reply.

    ~~I installed Antergos with KDE/Plasma. Isnt sddm the default kde login manager?

    Either way, sddm isnt enabled or running, so which login manager does it use by default? I need to disable that before installing and enabling sddm right?~~

    Scrap that, I was being lazy. Its lightdm and I disabled it, installed/enabled sddm and this part is working so the wallet is now unlocked at login.

    Hopefully someone can help me with the keys part.

    Thanks!

properly25 auto17 opening16 wallet5 Posts 3Views 184
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.