• pacman broke after update


    I didnt update for a long time (i know, bad habit) but know pacman is broken. The message I get is :

    sudo pacman -U --force /var/cache/pacman/pkg/openssl-1.0-0.0.2.o-1-x86_64.pkg.tar.xz 
    sudo: error in /etc/sudo.conf, line 0 while loading plugin "sudoers_policy"
    sudo: unable to load /usr/lib/sudo/sudoers.so: libssl.so.1.1: cannot open shared object file: No such file or directory
    sudo: fatal error, unable to load plugins
    

    I was trying to look here https://wiki.archlinux.org/index.php/Pacman#.22Cannot_open_shared_object_file.22_error
    or here https://bbs.archlinux.org/viewtopic.php?id=94902
    but somewhat pacman, even after creating the symlinks and reverting the openssl package to a previous version , ,gives an error (see code snippe)

    what to do?

  • so not pacman is broken, it is sudo…
    take su to get root and use pacman as root should work:

    su
    pacman -U --force /var/cache/pacman/pkg/openssl-1.0-0.0.2.o-1-x86_64.pkg.tar.xz
    
  • @fortini-david
    You could now try this to update the whole system:

    su
    pacman -Syyuu
    
pacman122 broke25 Posts 3Views 308
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.