• Get stuck at the password prompt


    Hey guys, :)

    I have a big problem. I can’t use my encrypted external hard drive when I plug it in I get the password prompt but I can’t cancel or decrypt wtf 🤷. How can I fix it please? Thanks 😘

  • will need more info on how do you encrypt the disk…

  • @joekamprad Oh a external hard drive ext4 luks. :)

  • @hostagekia said in Get stuck at the password prompt:

    luks

    do you try open it manually?

    cryptsetup open /dev/sdXn cryptname

  • @joekamprad no I think gnome can decrypt it but when I plugged it in my laptop the password prompt pop up I type the password and I can’t validate the password and can’t even cancel and get out of this prompt I need to reboot after get stuck.

  • Did you use special chars in your password?

    Maybe it’s a problem of keyboard map? I mean, that maybe when you created the luks device you were using an american keyboard mapping and you are using now another one? (or viceversa)

  • Or maybe the NumLock key is in wrong state?

  • @karasu Yes many special characters 😉 but it works on fedora 28 and Ubuntu too so 🤷

  • Yes, but Antergos = rolling release = more recent versions may causing little bug older versions do not have…
    So I would check open via terminal command to see if this is not caused by the mechanism used from GNOME itself.
    And check keyboard settings…

  • I was having the same problem recently in Gnome. Don’t know what is causing it… This is what I did to bypass the problem:

    1. I disabled USB automounting:

    gsettings set org.gnome.desktop.media-handling automount true
    gsettings set org.gnome.desktop.media-handling automount-open false

    1. now when I plug the external disk in, I can manually mount the luks partition with:

    sudo cryptsetup luksOpen /dev/sdb2 cryptpart
    sudo mkdir /mnt/crypthome
    sudo mount /dev/mapper/cryptpart /mnt/crypthome
    cd /mnt/crypthome

    1. when finished, umount it with:

    sudo umount /mnt/crypthome && sudo rmdir /mnt/crypthome

  • @knightfall so the cause is may on GNOME nautilus,

  • Nice I gonna try it =) thanks <3 @knightfall

  • @joekamprad very probable. I’ve seen this on a freshly installed Antergos + Gnome a couple of days ago. Not 100% sure but IIRC, even the live iso.

  • Well, it seems my temporary solution is not working anymore. I can reproduce the issue even with the live ISO (Gnome), but not on other desktops (I’ve tried xfce, kde, budgie) so I guess it’s definitely a Nautilus bug. The only way to prevent the prompt issue is to plug in the encrypted drive BEFORE logging into Gnome.

stuck46 password38 prompt8 Posts 14Views 701
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.