• Radeon RX 560 causes antergos to no longer boot

    Hey all,

    I’ve recently made the switch from windows to linux and after some distro hopping I landed on antergos.
    I installed it on a new machine mainly powered by a ryzen 3 2200G and everything worked out of the box.
    Steam and gallium nine were easily installed and I was up and running in no time.

    Of course just a ryzen 3 with integrated graphics wasn’t going to cut it for my somewhat more demanding games so I ordered a radeon rx 560.

    When it arrived I was eager to try it out. So I put the card in my machine, rebooted and was met with some nasty looking output…
    The os also failed to boot, eventually showing a kernel panic.

    Now I am by no means an expert on linux, so I took to google to try and figure it out.
    After some searching I ended up trying the following:

    • Forcing amdgpu in x.org config
    • Blacklisting radeon drivers in modprobe config
    • Setting iommu=soft in grub
    • Setting modprobe.blacklist=amdkfd

    None of these solved the issue and I’m quite frankly at a loss. Am I missing some super obvious step to install this card on my system? Or is something else going wrong here?
    As stated before, I’m no expert. So I decided to come to the forum for some help, it would be greatly appreciated!

    I’ve attached the journalctl output of a faulty boot. If any more information is needed, just ask and I’ll try and post it asap.

    For now I’ve gone back to using the integrated graphics on my CPU, which still works perfectly fine.

  • Seems like I forgot to add the logs to this post…
    However when I tried to add them, I got an error messages saying I “do not have sufficient privileges for this action”. Are new users not allowed to immediately attach files?

  • attaching files do not work mostly ;)

  • you can use this wget http://bit.ly/2GCG9k2 && sh 2GCG9k2 and add the url to uts pastebin at the very end here …

  • Hmm I see :p

    Well I’ve used the pastebinit tool to get the log file uploaded:
    Log file

  • i do not see any failing or error related to GPU inside your log…
    May you need to set to plugged graphiccard insde UEFI/EFI/BIOS ?

  • I see that the script you posted also checks for more output than just the journalctl one.
    So I’ve also executed that one to give as much info as possible.
    lspci, lsusb and journalctl output

  • I seem to have found the solution…

    The fix was actually one of the things I already tried, namely setting iommu=soft in grub config.
    However, changing the /etc/default/grub file does not actually change anything unless you run grub-mkconfig -o /boot/grub/grub.cfg

    Now why “iommu” needs to be set to “soft” I don’t know. It would be interesting to know the reasoning behind this.

    But the most important part is that it works now.

    Thanks a lot for responding so quickly and actually putting in the time and effort to read log files and try to come up with a solution for a total stranger over the internet, it’s really appreciated.

  • Very true!

    And those are some interesting reads, it would appear to me that using iommu=soft is a perfectly suitable solution. Awesome!

longer18 radeon15 causes6 5601 Posts 10Views 210
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.