• New installer is broken

    But ZFS option is screwed up as i can see here on testing it… it do not give account info slide and start install without asking then… and after install packages it hangs on the last one without error:



  • Hi,

    I’ve fixed the not asking user screen when using zfs.

    Even that, it still freezes because of “not enough free memory”:


    More tests are needed.

  • @karasu
    I tried zfs install but the installed system didn’t boot after the install. But I’m quite unsure about zfs since I haven’t installed a zfs system before, so I may have given wrong input to the installer.

    This is the cnchi.log: https://ptpb.pw/aG02
    So the installer got stuck apparently while installing the last package. Then I waited a bit and assumed install was ready, and rebooted, but it didn’t boot, but showed lots of some isolinux lines like:

    isolinux: Found something at drive = F6

    and there it stopped completely.

    So my question is: what input should I give to the installer about zfs?
    I used MBR and not GPT, does that matter?

    I’d like to install only a minimal set of a working zfs into a VM, and I think I already did that, but not exactly sure it was correct.

    I can assign much more RAM to the VM than 2GB, so that shouldn’t be a problem.

  • @karasu
    I tried installing again.

    Now I noticed that in the end after seemingly installed all packages, it seems to get stuck. But it doesn’t.

    It just does something (compiles stuff, keysyms etc.) for about 10 minutes and then asks for a reboot. It doesn’t show visually any information it is still doing, nor it doesn’t ask user to wait. This should be addressed. I really thought it was permanently stuck, but it wasn’t.

  • I’ve tried the installer today (ext4, not zfs) on my office network and it worked fine, except for the connectivity check. Apparently the IPs it tries to connect to are blocked by the firewall so cnchi reports no connection available. I simply patched the function to always return True and it worked.

  • @knightfall
    Interesting. Well done! :)

  • Good Morning

    I would like to know if for me to use ZFS I need some additional configuration, or just install normally?
    I tried it several times but I never managed to use ZFS, I also could not use it in the previous versions.

  • @knightfall

    There is a --no-check (or -n) option that does that, but I like your resourcefulness.

    As @manuel has found out, you must wait at least 10 minutes after finnishing zfs installation (wait until the reboot message appears). I must fix this for sure.


    Thanks a lot!

  • I would like to install ZFS, I get all the way to the last setup slide and instead of clicking forward I go back a slide and that’s how I get the setup user accounts section, but at the very end of install I get Antergos installer-error, cannot allocate memory. I can leave it for half hour, but does not boot after restart. Regular install works though.

  • @Listening said in New installer is broken:

    I get Antergos installer-error, cannot allocate memory.

    Yep, I’m really sorry about this. I haven’t got any time to try to fix this one.

    Just out of curiosity, how much RAM memory do you have? (I do not think that’s relevant, but who knows…)

  • @karasu

    No need to say sorry, I am very satisfied with your distro :)
    I have 8 GB of ram.


installer65 broke25 Posts 52Views 5580
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.