• Is it possible to block a dependency from being installed?


    Antergos-openbox-meta installs gnome-disk-utility and file-roller, I hate how gnome apps don’t use my system theme so i want to remove them but I cant. I can use “pacman -Rdd” but when antergos-openbox-meta updates it will bring them back so is it possible to just block them from being installed? I tried Noextract in pacman.conf but it did nothing, any help is appreciated.

  • @aesyir
    NoUpgrade in pacman.conf should do the job. Note that it is case sensitive.

    But dependencies are there for a reason. Some programs may not work properly if their dependencies are blocked.

  • @manuel I know it could be dangerous (I do have daily backups setup tho) but would putting “gnome*” block all packages that start with the word gnome?

  • @aesyir
    I suppose yes, but haven’t tested it.
    And you could try IgnorePkg in pacman.conf.

    Command

    man pacman.conf
    

    shows more info.

  • I am no openbox guy but in general if you want to avoid things you don’t want you have to stay away from metas or even have to build your own package.
    In my opinion there should be always the pure software without any optional dependencies but unfortunately this isn’t the case…

  • I would hint that keeping the meta-package and ignoring GNOME* packages will bring you the same amount of problems or more then have your own openbox package-list… as openbox is functional as a package and its lean deps alone…

dependency24 block4 Posts 6Views 268
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.