• Strange wireless issue


    Hello,
    I am using a Tenda wireless USB Ethernet adaptor. It seems to be fine but I am getting periodic lag when playing WOW through wine. I do not receive the lag in Wow when playing on windows 7 but I do in linux. It does not seem to be specific to Antergos either as I have experianced the same issue in Linux Mint, Ubuntu, Arch(base system) and Cinnarch. Any ideas or suggestions ?

  • Hello,
    I am using a Tenda wireless USB Ethernet adaptor. It seems to be fine but I am getting periodic lag when playing WOW through wine. I do not receive the lag in Wow when playing on windows 7 but I do in linux. It does not seem to be specific to Antergos either as I have experianced the same issue in Linux Mint, Ubuntu, Arch(base system) and Cinnarch. Any ideas or suggestions ?

  • Do you ever connect using your Ethernet port? The reason I ask is because I use my laptop both docked on my desk as well as mobile and I have noticed my connection slowing to a crawl sporadically. If I manually disable wifi when plugged in and vise-versa everything is fine. Its strange behavior thst I have duplicated in openSUSE and Linux Mint unfortunately :-/

    Some things to check:
    [list:2wbjg7xt][*:2wbjg7xt]Use iwpriv to configure device[/*:m:2wbjg7xt]
    [*:2wbjg7xt]Ensure power save is turned off via iwconfig[/*:m:2wbjg7xt]
    [*:2wbjg7xt]Since it is USB, you want to disable usb auto suspend either altogether or for the wifi card specifically.[/*:m:2wbjg7xt][/list:u:2wbjg7xt]

    Here are some links:
    [https://wiki.archlinux.org/index.php/Pm-utils][0]">[https://wiki.archlinux.org/index.php/Pm-utils][1]
    [https://wiki.archlinux.org/index.php/Power_saving#USB_Autosuspend][0]">[https://wiki.archlinux.org/index.php/Po][2] … utosuspend
    [https://wiki.archlinux.org/index.php/Wireless_Setup][0]">[https://wiki.archlinux.org/index.php/Wireless_Setup][3]

    Good luck!

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Pm-utils
    [2]: https://wiki.archlinux.org/index.php/Po
    [3]: https://wiki.archlinux.org/index.php/Wireless_Setup

  • when i check iwconfig i get this

    wlp0s26u1u2 IEEE 802.11bgn ESSID:"Tenda\_50F428"   
    Mode:Managed Frequency:2.437 GHz Access Point: C8:3A:35:50:F4:28   
    Bit Rate=86.7 Mb/s Tx-Power=20 dBm   
    Retry long limit:7 RTS thr:off Fragment thr:off  
    Power Management:on  
    Link Quality=70/70 Signal level=-39 dBm   
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0  
    Tx excessive retries:25 Invalid misc:46 Missed beacon:0  
    
    

    Then i run

    sudo iwconfig wlp0s26u1u2 power off
    

    and i get this

    wlp0s26u1u2 IEEE 802.11bgn ESSID:"Tenda\_50F428"   
    Mode:Managed Frequency:2.437 GHz Access Point: C8:3A:35:50:F4:28   
    Bit Rate=78 Mb/s Tx-Power=20 dBm   
    Retry long limit:7 RTS thr:off Fragment thr:off  
    Power Management:off  
    Link Quality=70/70 Signal level=-23 dBm   
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0  
    Tx excessive retries:27 Invalid misc:47 Missed beacon:0
    

    Then i reboot and i am back to the original status of power management:on

    How can i make the setting save ?

  • Remove from AC power, this needs to be done using battery power only. Next, run the same commands you ran in your last post to verify PM is on and then turn it off. Now, to make the setting persistent run the following commands in terminal.

    cd /etc/pm/power.d  
    sudo nano /etc/pm/power.d/wireless  
      
    Input these two lines and then save/exit (Ctrl+O,Enter,Ctrl+X)  
      
    \#!/bin/sh  
    sudo iwconfig wlp0s26u1u2 power off
    

    That should do the trick!

Posts 5Views 1406
Log in to reply