• Cnchi 0.16.1 is out!


    Hi there!

    We’ve just released a new version of our installer.

    Two BIG changes:

    • When an error occours, Cnchi will inform the user which package is failing (to download or to install), so it shouldn’t be necessary to check the logs.
    • Logs are created in /var/log/cnchi folder (so don’t look for them in /tmp anymore).

    These are the changes/modifications/fixes:

    • Cleanup code [code]
    • Do not use defusedxml [code]
    • Updated Readme.md
    • Split ZFS code in two modules for better readability (zfs, zfs_manager) [code]
    • Changed ZFS disk structure
    • Use sha256 sum when checking downloaded files (instead of md5)
    • Merged lembrame code
    • Install yay as AUR helper
    • Move LUKS code from auto_partition to its own module (luks) [code]
    • Move mount functions from auto_partition to its own module (mount) [code]
    • Split mkinitcpio code into several functions [code]
    • New class Events to manage… events. Removed queue_events function from several modules. [code]
    • Do not use meta packages in packages.xml
    • Added i3 and Budgie to available desktops
    • Use /var/tmp instead of /tmp
    • Store logs in /var/log/cnchi instead of /tmp
    • self.ui got renamed to self.gui
    • Be able to boot when /usr is in a separate partition
    • Removed apply button in avatar choosing dialog (just double click on the wanted image)
    • Once the packages list is created, check that there is no removed/renamed package in that list that will break the installation
    • Set MIN_SIZE for the installation to 16 GB (instead of 8 GB)
    • Fix user info page when going back and forth
    • Set valign to center in some screens
    • Get Cnchi latest stable version from antergos repository database (antergos.db)
    • Fixed rank_mirrors (using https:// for Antergos mirrors)
    • Enable multilib if disabled on pacman.conf
  • @karasu

    Somehow, Cnchi doesn’t start at all. I tried it on the live and minimal iso but i can’t install anything anymore. Is it because of this update?

  • cnchi wont loading after update i cant install antergos.

  • @pedrozun Same for me. Can’t install anything. Too bad. Hope the fix will be out soon.

  • @karasu
    What is the the proper command line to start cnchi installing on the 18.9 ISO?

  • @karasu
    With ISO 18.8 cnchi does not start by itself. I can update cnchi to 0.16.1 (only) manually. But cnchi does not start with the icon, and on terminal, cnchi command just shows:

    [[email protected] ~]$ cnchi
    usage: cnchi.py [-h] [-a] [-c [CACHE]] [-d] [-e [ENVIRONMENT]] [-f] [-n]
                    [-p [PACKAGELIST]] [-t] [-v] [-V] [-z]
    cnchi.py: error: unrecognized arguments: -s bugsnag
    [[email protected] ~]$
    

    With ISO 18.9 cnchi does not start, and I cannot update cnchi at all. On terminal it again complains about bugsnag as above.

  • @manuel said in Cnchi 0.16.1 is out!:

    @karasu
    With ISO 18.8 cnchi does not start by itself. I can update cnchi to 0.16.1 (only) manually. But cnchi does not start with the icon, and on terminal, cnchi command just shows:

    [[email protected] ~]$ cnchi
    usage: cnchi.py [-h] [-a] [-c [CACHE]] [-d] [-e [ENVIRONMENT]] [-f] [-n]
                    [-p [PACKAGELIST]] [-t] [-v] [-V] [-z]
    cnchi.py: error: unrecognized arguments: -s bugsnag
    [[email protected] ~]$
    

    With ISO 18.9 cnchi does not start, and I cannot update cnchi at all. On terminal it again complains about bugsnag as above.

    same problem here.

  • I can’t even boot the 18.9 iso ( But 18.8 should work as well?)
    Hope they fix this soon.
    Is there any way to manually start Cnchi?

  • cat /usr/bin/cnchi
    
    #!/bin/bash
    
    pkexec /usr/share/cnchi/bin/cnchi -s bugsnag ${@}
    

    on try running pkexec /usr/share/cnchi/bin/cnchi
    i got:

    2018-09-25 20:03:08 [ERROR ] Cannot create Cnchi main window: No module named 'maxminddb' (cnchi.py:102)

  • So I can’t even install because Cnchi won’t allow me to proceed with installation without internet connection and when I plug internet cable in it will update automatically without even asking. Wow, now I feel like using microsoft os.

  • @karasu
    With ISO 18.8 and cnchi 0.16.2-2, install will not start. On terminal the output is:

    [[email protected] ~]$ sudo cnchi
    2018-09-26 08:25:40 [WARNING] Bugsnag disabled. Makes requests raise several exceptions. Need to check what is wrong  (cnchi.py:340)
    2018-09-26 08:25:40 [DEBUG  ] All repositories are present in pacman.conf file  (cnchi.py:266)
    2018-09-26 08:25:40 [INFO   ] Using GTK v3.22.30  (cnchi.py:375)
    2018-09-26 08:25:40 [INFO   ] Using pyalpm v0.8 as interface to libalpm v11.0.1  (cnchi.py:387)
    2018-09-26 08:25:40 [DEBUG  ] Running from ISO version 18.8  (cnchi.py:411)
    2018-09-26 08:25:40 [DEBUG  ] Running set on gsettings: runuser -l antergos -c dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type nothing   (cnchi.py:579)
    2018-09-26 08:25:40 [DEBUG  ] Running set on gsettings: runuser -l antergos -c dbus-launch gsettings set org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type nothing   (cnchi.py:579)
    2018-09-26 08:25:40 [ERROR  ] Cannot create Cnchi main window: No module named 'maxminddb'  (cnchi.py:102)
    [[email protected] ~]$
    
  • @manuel

    Same thing for me. The interesting thing is, when i launch Cnchi before any updating, the older version launches. But if i wait for the update to finish, the same error as yours appears.

  • @tastaturri and all

    With ISO 18.9 the install starts OK!!
    I’m just installing Xfce and see what happens. Will inform here about the results!

  • So, cnchi updates itself properly to 0.16.2. Still waiting for the install to finish…

  • The thing is i can only boot the 18.8 iso. With the 18.9 iso i can’t even get in the live os without some efi error.

  • Unfortunately installing is now stuck at “Installing bootloader”.
    /var/log/cnchi/cnchi.log:

    [[email protected] cnchi]$ tail -f cnchi.log 
    gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=985)
    /dev/sda2 on /install type ext4 (rw,relatime,data=ordered)
    /dev/sda1 on /install/boot type ext4 (rw,relatime,data=ordered)  (run_cmd.py:106)
    2018-09-26 08:39:37 [DEBUG  ] Unmounting /install/boot  (mount.py:37)
    2018-09-26 08:39:37 [DEBUG  ] Unmounting /install  (mount.py:37)
    2018-09-26 08:39:39 [INFO   ] Installation finished  (slides.py:226)
    2018-09-26 08:39:39 [DEBUG  ] Starting new HTTP connection (1): build.antergos.com:80  (connectionpool.py:205)
    2018-09-26 08:39:39 [DEBUG  ] http://build.antergos.com:80 "GET /hook?cnchi=2580656b5c7be34e4144a3129a95e421 HTTP/1.1" 301 None  (connectionpool.py:393)
    2018-09-26 08:39:39 [DEBUG  ] http://build.antergos.com:80 "GET /api/hook?cnchi=2580656b5c7be34e4144a3129a95e421 HTTP/1.1" 200 None  (connectionpool.py:393)
    2018-09-26 08:39:43 [WARNING] Error running ['/usr/bin/pidof', 'grub-mount']: b''  (grub2.py:265)
    
  • @tastaturri
    Oh yes, forgot that I had the same problem with 18.9 ISO on a physical machine.
    Currently I’m testing on a VM, that seems to boot 18.9 OK.

  • This post is deleted!
  • @manuel

    Give it time to the bootloader installation… I haven’t experienced this in my end ¿?

    I will test it again myself asap.

  • @karasu
    Now I’m testing ISO 18.9 with Xfce on a VM. Cnchi updated to 0.16.3-2 automatically.
    Keyboard is also automatically correct on terminal now.

    But again it is stuck on Installing bootloader...
    It has been stuck for 11 minutes now. I’ll wait a bit more…

cnchi161 out2 0.16.11 Posts 39Views 3749
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.