• Cnchi 0.16.1 is out!


    @karasu
    Still stuck… has been stuck for 20 minutes.
    Here’s the /var/log/cnchi/cnchi.log: https://ptpb.pw/FxpS

  • Spent all afternoon and night with the same issues.

    18.9 is stuck on installing bootloader.
    18.8 updates cnchi to a point where it is unable to start giving the maxminddb error. I think I may have found a work around of turning on and off internet at the right points, so I could get through the install without it updating cnchi. Currently installing this way and hoping it will work.

    Very disappointed that an iso this broken got installed, and then cnchi updated with no checks for backwards compatibility. There should at the very least always be some way to install antergos.

  • Can confirm my workaround by disabling internet in the 18.8 ISO, worked for the install. So to anyone else unable to install, get the 18.8 ISO, turn on internet, right when you get by the internet check disable it again. Then go all the way until it asks you to wait while it refreshes repositories, enable it again. Now rush through the last parts of the install before it closes the installer down, and hopefully the installation should start before it closes down.

  • @mperorm
    Yup, got it installed with this workaround.

    A bit easier workaround (with 18.8 ISO) is to let cnchi update itself and then quit it and downgrade it with these terminal commands:

    su
    pacman -S downgrade
    downgrade cnchi  # to 0.14.426
    

    and then start cnchi from the blue icon on the left.

  • Hi,

    Cnchi 0.16.3 shouldn’t stop on bootloader installation.

    Anyway, all installations done with Cnchi 0.16.2-2 are ok… just reboot when it stops responding when installing the bootloader and reboot… everything will be ok.

    Cheers!

  • @karasu
    I agree, it shouldn’t… but it does.

    And right, when it gets stuck at installing the bootloader, you need to wait a minute and just reboot. The installed system starts OK (I’m currently testing it on a VM).

    But I noticed a new minor issue: command pacman is aliased to sudo pacman in ~/.bashrc.aliases. I haven’t noticed that alias before, and I suppose it is some personal settings or testing leftover?
    Also there is an alias like auru that uses obsoleted yaourt.

  • @manuel said in Cnchi 0.16.1 is out!:

    I agree, it shouldn’t… but it does.

    Version 0.16.3 ??? It doesn’t happen here. I will retest it today, just in case.

    But I noticed a new minor issue: command pacman is aliased to sudo pacman in ~/.bashrc.aliases. I haven’t noticed that alias before, and I suppose it is some personal settings or testing leftover?

    Yep… this is a mistake. Easy to fix. Will do when I get home.

    Also there is an alias like auru that uses obsoleted yaourt.

    Ups… this is an old alias. Will remove it asap, too.

  • @karasu

    Version 0.16.3 ???

    Yes.
    It might be a VirtualBox issue, since I’m running the installer on a VirtualBox VM.

    By the way, I previously reported (a couple of weeks ago probably) a peculiar behavior on one of my machines, the UEFI based laptop (HP) I bought this Summer. Now I tested it a bit more, and this is what I get:

    With a 18.9 USB installer, it cannot boot at all if I select
    Antergos Live System (usb)
    but it can boot if I select
    Antergos Live System (cd/dvd)
    The default is the usb alternative, and for me it sounds to be the right one.

    Would you please explain the logic/purpose behind the usb and the cd/dvd alternatives?

    And thanks for the cleanups.

  • @manuel said in Cnchi 0.16.1 is out!:

    By the way, I previously reported (a couple of weeks ago probably) a peculiar behavior on one of my machines, the UEFI based laptop (HP) I bought this Summer. Now I tested it a bit more, and this is what I get:
    With a 18.9 USB installer, it cannot boot at all if I select
    Antergos Live System (usb)
    but it can boot if I select
    Antergos Live System (cd/dvd)

    It happens not only on laptops, but also on desktop systems. It also happens not only on UEFI, but also on BIOS. Have the same issue with 18.9 on UEFI laptop and BIOS desktop computer.

  • @manuel VirtualBox is booting emulated cd/DVD out of ISO Files…

  • Hi, same problem here, is there a solution already? (“Cannot create Cnchi main window: No module named ‘maxminddb’”) (Using Antergos 18.8) (Downgrading does work but the installer later fails (in the screen where the user info is asked just after setting up the partitions) with a pop up message with code: 0 and in the terminal a JSONDecodeError can be seen from loggin_utils.py (212) send_install_result() (‘Expecting value: line 1 column 1 (char0)’,) along with many other errors before that… what’s happening??

    Edit: it seams that if your fast enough on that last screen (when it asks for the user info) (or just persuasive enough and you keep on trying) it will actually let you install Antergos on this computer… :-/ …

  • Hi @fred

    It’s not straightforward to use an old ISO with a new version of the installer.

    What’s wrong with the latest ISO? It does not boot for you or what?

    Going back to your error Cannot create Cnchi main window: No module named ‘maxminddb' it’s just that you’re missing a new dependency. Just install python-maxminddb with sudo pacman -S python-maxminddb

    Anyway, I’m sure more dependencies are missing if using an old ISO… (at least, python-libnacl and python-feedparser are the ones that come to mind).

  • Hi,
    I’m sort of new here but i’ve been trying to reinstall but on reinstall i’m getting the same error that manuel is talking about. same exact error message when i try to run cnchi after update via terminal. I tried karasu’s solution of installing maxminddb with pacman using sudo pacman -S pythin-maxminddb but i still get the same error. Even when i close the terminal and start a fresh one. same exact error. I’m also on version 18.8. I’m going with the route that manuel suggested but to be clear for anybody else you’ll want to say yes when it asks to add cnchi to ignorePkg. Going through the process now, so far so good

  • @kryptic_kay9 said in Cnchi 0.16.1 is out!:

    version 18.8

    why version 18.8 ? and not latest ISo 18.11 ?

cnchi154 out2 0.16.11 Posts 34Views 2324
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.