• Canot create partition tables on any USB or MMC cards


    No matter what utility I use to prepare MMC cards to make bootable media, I get input output errors or libparted errors… and nothing seems to work.

    When I try Gparted and Kvpm to format the cards I get libparted errors. deleting the partition seems to work, but they remain unchanged once remounted, so I try to just create new MSDOS partition tables and get input output errors.

    I have reinstalled Gparted and libparted and installed Kvpm (never tried it before) but no change, I tried the cards in the card reader, as well as with an MMC to USB adapter, and both work just fine with other cards I have data on and those from my camera. All of these cards work and I can read and navigate them in dolphin accept for the boot sectors of course, even after all of the above attempts to clear them!

    I looked High and low for related bugs, but can’t find anything more recent, and none of the solutions from months and years ago work either, so What on earth could be the problem?

  • @zoidmo
    Partition should not be mounted while performing operations to it e.g. with gparted.

    If you umount all partitions on a disk/stick, can you create a partition table (gpt or msdos) to it?
    Gparted is a good program for these operations.

    If it is not working, could you show the error messages here (start gparted on a terminal: sudo gparted)?
    And could you also show the output of command

    sudo fdisk -l
    

    when a problematic USB or MMC card is connected?

  • i would try erasing this cards first with dd but take care to do NOT erase the wrong one !

    get device name with sudo fdisk -l and run dd like this (replacing /dev/sdX with the device you want to erase)

    sudo dd bs=4M if=/dev/zero of=/dev/sdX status=progress && sync

    But take realy care as dd is known as destroyer of disks

  • @manuel I know that already Both Etcher and WoeUSB have the requirement to unmount the drive, but that is not the problem. I just bought a new MMC card and tried WoeUSB again, but it failed and I tried every documented solution. Now I am running Etcher and making a Linux Mint installer as we speak…Flashing… one minute please… Validating… Success, or at least so far.

    So although it seems that there is something wrong with the MMC cards, I still have a hard time believing they are bad, because “Card 1” one is not old and hardly used, and the other “Card 2” has only been used once to install Antergos, and I bought it because I had similar problems in the past: after Installing Antergos once with “Card 1”, The installer did not work anymore, Etcher wouldn’t burn the installer to it, and I had to use gparted to fix it, and that only worked in steps because gparted could not read the card after each step so I had to: Delete partition, close and restart gparted, create partition table, close and restart gparted, create new partition. After that I could burn the Antergos installer to it, Install it on another PC, and just for kicks tried booting from the card, and it was busted again.

    I have installed Antergos for various reasons like 5 times, in the last few years, and always had to do it that way, and this time nothing works!

    Anyhow fdisk reports this:

    Disk /dev/sdg: 7.4 GiB, 7948206080 bytes, 15523840 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x00000000
    

    Not having a disk identifier is odd, but I can still read and navigate the card in dolphin. XXXXXX

    Well, before I wrote this reply, I was away for a few hours with the PC running, then I started writing up to XXXXXX, Installed an update (upgraded dconf-editor 3.30.0-1 -> 3.30.2-1) after which I just tried gparted again to copy and save the error, and it worked all of a suddon, and with both cards 1 & 2!!! What the??? The only difference I noticed is that the partitions (only one each) showed up as unallocated, even though I just navigated them in dolphin, not 10 minutes ago!

    ARRRRRGH!!! This makes no sense at all, but I do have other strange things happening, mainly with KDE Plasma acting all crazy sometimes!

    I would love to still figure this out, do you think if I run the Antergos Log file script, and attach the files to a reply (if I have enough privilege) it may show what the wierdness is going on?

    I would think my computer is possessed, but I don’t believe in the supernatural!

  • @joekamprad Ha Ha I know, isn’t that what dd stands for? “Disk Destroyer”, or is it “Demolish Disks”?

  • @zoidmo
    If I remember correctly, MMC card does not really support that it would be an installer disk. I may be wrong, or this may have been the case with older MMC or SD cards.

    Anyway, disk identifier 0 seems strange. If you create a new partition table (e.g. gpt), does it then show a reasonable disk identifier?

  • @manuel They are SD cards, MMC (Multi Media Card) is a blanket term covering the different types like Micro SD, M2, Xd… used by different devices like cameras etc, My card reader can handle a few different types, but I never had anything but SD cards, since the others never got popular.

  • @zoidmo said in Canot create partition tables on any USB or MMC cards:

    MMC

    i have a sd-card adapter for usb and i can use this to boot Antergos ISO and writing image with etcher or dd is working …

  • @joekamprad
    OK, my info then is either outdated or plain wrong.

  • @manuel i am not sure here… i remember also using one of thouse bigger CF (compact flash) cards to have a rescue system aviable… but i do not burn the ISO on it… i just install a rescue system on it…

  • @joekamprad
    If it can boot, then I suppose it can install.

  • I think they all run on USB accept for maybe lower voltage on the tiny ones.

  • @manuel said in Canot create partition tables on any USB or MMC cards:

    @joekamprad
    If it can boot, then I suppose it can install.

    yea but only if you are able to get the image (ISO) on it :)

    @zoidmo you can also only remove MBR section of a disk:

    sudo dd if=/dev/zero of=/dev/sdX bs=512 count=1

  • I am taking notes for the future, but I still would love to know why I keep running into problems that just dissapear, or change slightly!!!

    My 1920x1080 Monitor blew up about a week ago, so I swapped it for an old IBM Thinkvision at 1280x1024 until I got a new one, and I got all crazy artifacts on the screen and the cursor would go below them when moved, and my Plasma menu bars started flipping out flickering on and off going from hidden to shown. I added the new monitor Yesterday the menu bars are still flipping out, just on the new monitor, and the artifacts are still on the old one!!!

    I need a new computer, and the money to buy one! I have had all kinds of stuff breaking and needing replacement in the last 2 months: My TV, car breaks (rotors and discs), the refrigerator, my shoes, my soldering station! I had to fork over ~$ 2000 just for a new fridge and monitor and stuff! If this continues my brain will blow out too! 🤯 (Kapoofkaa!!!) 🤕

usb115 partition41 canot1 tables1 Posts 16Views 423
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.