• Trouble with HP ZBook Studio G5 x360 (Nvidia P1000+i7-8850H)


    This post is deleted!
  • This post is deleted!
  • [   19.500143] psmouse serio3: synaptics: Your touchpad (PNP: SYN307b PNP0f13) says it can support a different bus. If i2c-hid and hid-rmi are not used, you might want to try setting psmouse.synaptics_intertouch to 1 and report this to [email protected]
    [   19.582566] psmouse serio3: synaptics: Touchpad model: 1, fw: 10.16, id: 0x1e2a1, caps: 0xf00123/0x840300/0x12e800/0x500000, board id: 3398, fw id: 2763040
    [   19.631594] input: SynPS/2 Synaptics TouchPad as /devices/platform/i8042/serio3/input/input14
    
    
  • okay, with the command line I mentiones before (acpi_osi) it works now. The only thing that does not work now is the brightness fn keys, the touchpad switch fn key, and the touchscreen itself.

  • @popkultur
    Thanks so far for reporting all your findings here! It will help others with the same machine as yours.

    BTW, if the brightness issue only with non-functional fn keys, or is brightness setting totally unavailable?

  • no, just with the keys. It can be controlled via the menu. It can also be switched on and off by “xinput disable 12” and “xinput enable 12” (id might change though). I have submittet a ticket to the Linux Wacom Project because the touchscreen is a wacom one. Seems there is just an entry in the library missing.

  • acpi_listen gives me same code for three keys (brightness up/down and microphone). So I think it is a kernel issue, I won’t be able to assign this keys seperately.

  • I have the same device and so far able to make installation success, but never able to make touchpad works. (brightness fn key issues seems unfixable as said). I tried acpi_osi kernel param but no luck, anyone able to figure it out a correct way?

  • There is a bug report on kernel.org for this type of touchpad, it should be fixed sometime in the future. If you try the acpi_osi=“Windows 2017” it should work though.

    I found out one might also get the fn keys to work, if the driver is switched to PS/2 keyboard somehow. But I don’t know how to do this in Linux.

trouble17 studio4 zbook2 x3601 Posts 29Views 1517
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.