• Trouble with HP ZBook Studio G5 x360 (Nvidia P1000+i7-8850H)


    Hi,

    just to inform you that there is big trouble installing this notebook with antergos, although hp claims it would work with Linux. It has a Intel® Core™ i7-8850H and a NVIDIA® Quadro® P1000

    I run into several problems. Many boot options run into a vmlinuz not found, even with secureboot disabled and legacy boot. fast boot cannot be switched off. I tried hybrid graphics in bios as well as dedicated graphics. Other boot options like minimal iso or cd/dvd live boot just freeze with some messages. It seems both the processor/bridge as well as the nvidia card are not yet supported well. I’m running out of options.

  • @popkultur
    Have you checked this: https://wiki.archlinux.org/index.php/HP_Zbook_Studio_G3
    It is not the same, but the tips just might help.

  • @popkultur
    One question: how did you create the USB installer stick?

  • Thanks, I am not sure if the wiki will help me, I will read through it again. I created the installer stick both with etcher and with dd without further effect. I had the idea to try some test builds and see if it helps?

  • do you try?:
    Using hybrid graphics
    Due to a kernel issue, use of nouveau or bbswitch may result in lockups. To prevent this, add acpi_osi=! acpi_osi=“Windows 2009” to your kernel command line

  • Did not help, it stopps with “attached SCSI removable disc”. Probably NVME…?

  • Did not help, it stopps with “attached SCSI removable disc”. Probably NVME…? Actually it stopps at the scsi disk message when using mini imane. with regular image, it stopps much earlier after ACPI Error.

  • it stopps after running “early hook plymouth”

  • @popkultur
    Do you have package plymouth installed? I don’t on Xfce.

  • @manuel he is trying to boot liveISO and this is still using plymouth to show boot logo ;)

  • @joekamprad
    Thanks, my bad. :)

  • @popkultur 0_1537944622488_IMG_20180926_084547.png
    It looks to my like your card is not supported by open source nouveau driver.

  • yes, that might be it. So I would have to use the nvidia fallback option, which unfortunately does not work because of the “vmlinuz not found” problem.

  • @popkultur
    Since your machine seems to have also Intel graphics, maybe that would work (although not as fast, but takes less power).

    So you could uninstall and/or blacklist all Nvidia related drivers and modules and use Intel video. That should work. If it doesn’t work directly, you could delete (or move to another folder) some nvidia related files from /etc/X11/xorg.conf.d/.

  • I got it to run with “nouveau.modeset=0 nouveau.blacklist=yes modprobe.blacklist=nouveau” without using nvidia or nouveau drivers. It uses now intel Drivers. I hope there will be nouveau or nvidia support in the future!

  • next problem I am running into are the special fn keys which seem not to work yet. Will have some research what to do about it in the wiki.

  • after adding acpi_osi=! acpi_osi=“Windows 2017” everything except brightness works now.

  • nvidia support should be present ;) but not an booting the ISO, you can install drivers with the nvidia-installer script from Antergos:

    https://antergos.com/wiki/hardware/graphics/antergos-nvidia-installer-2/

  • I had to kill cnchi once while it froze sorting the mirror list. Smooth Linux Installation is different.

  • Now it froze while installing the bootloader.

trouble20 studio5 zbook3 x3602 Posts 29Views 1644
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.