• Libreoffice Fresh 6.1.1 freezing/high CPU usage under KDE - solution!


    I had a problem using Libreoffice Fresh 6.1.1 in KDE when trying to save a document using the ‘Save as’ option. This causes Libreoffice to freeze, with soffice.bin using 100% of one of the CPU cycles. Doing a force quit then results in the process lo_kde5filepick running at 100%. This continues unless this process is also forced to quit.

    Others have had the same problem, see:
    https://bbs.archlinux.org/viewtopic.php?id=239795
    https://wiki.archlinux.org/index.php/LibreOffice#Theme

    This seems to be related to Libreoffice Fresh now using KDE dialogues for saving new files. A temporary fix is to enable SAL_USE_VCLPLUGIN=gtk3 in /etc/profile.d/libreoffice-fresh.sh by uncommenting this line. This results in Libreoffice going back to using the GTK ‘Save’ dialogue and prevents any freezing or high CPU usage for me.

  • @xler8 thanks for sharing a solution!

  • @Xler8
    Have you tried the updated Libreoffice fresh 6.1.1.3? That update followed fairly quickly, maybe it will solve the problem. I can’t tell, because I didn’t experience that problem in the first place.

  • @bryanpwo

    Thanks for the suggestion. Already using 6.1.1-3 when I noticed the problem, although it may have been there for a few days before. Will wait for next update to Libreoffice, but problem solved in the meantime. Was using Gnome for so long that GTK dialogue doesn’t feel out of place!

  • But only a text editor, so loaded processor? ☺

kde206 libreoffice18 Posts 5Views 511
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.