• Gnome 3.30 shutsdown computer instead of suspend?


    I now have the issue of my system shutting off after I logout. It doesn’t do it right away, it suspends but then I come back an hour later and it has shutdown.

    The power handling in the latest Gnomes just makes me want to scream. I want to have my computer do what I want not what the Gnome team THINKS I want.

    Does anyone have a good explanation of how the power management works, it’s like black magic now.

    Very much appreciate any answer , thank you.

    George

  • provide some info about your system and the journal may help to see what is wrong… / fails … e.t.c.

    https://antergos.com/wiki/miscellaneous/how-do-i-include-system-logs-when-asking-for-help/

  • Here is the log https://pastebin.com/QRHNH75f

    As you can see at 22:02 the system shuts down and I wake it up at 8:47 the next day. I did not use the system after 18:30 that day. My Power manager setting has Automatic Suspend Off

    Systemd seems to just takeover and shutdown the system. I’ve searched for how this happens but it seems very convoluted and it would be nice to have a clear explanation of how all this works, I just can’t seem to find one on the net.

    Thank you
    George

  • Sep 22 22:02:26 ve7frg kernel: PM: Image not found (code -22)
    
  • What does image not found mean, which image, an image of what exactly?

  • suspending is writing a systemimage from what it wake up the systemstate on resume…

  • Any clues as to why it can’t find it then?

    Further to that is there any really good information that would let me only suspend manually or shutdown manually, any other time just leave everything running but blank screens and enable the screen lock? Gnome seems to want to do all sorts of stuff automagically.

  • Yes I read that but Gnome seems to override all that somehow. I’ll go back and read it again though. Thanks.

  • I just wish Gnome would blank and lock my screen and leave everything else up to me.

  • i can have a look inside the changes on GNOME 3.30 update tomorrow… (now + 16 hours)

  • Possible solution could be disable the suspend features in GNOME control center or with gsettings…

  • Check this in a terminal:

    gsettings list-recursively | grep -i "suspend\|sleep"
    
  • This post is deleted!
gnome350 Posts 14Views 686
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.