• Keyboard and touchpad don't work on boot/reboot

    I have budgie desktop installed on my Acer laptop. When I boot my machine, the laptop’s keyboard and touchpad don’t work. What I do is connect a USB mouse which works fine, suspend the laptop on the login screen, wake up (still not working), suspend again, wake up and they’re working fine. After they’re working, any suspend operation works fine, but a reboot will repeat the issue. The laptop’s keyboard works fine on terminal (if I switch using ctrl-alt-f2)

    I don’t know where to begin debugging this issue. It’s good that I found a workaround, but it’s really annoying when I reboot my laptop, I may not have the USB mouse/keyboard present to do this sequence.

  • As Antergos do not ship Budgie by default, it will be only a little users here with knowledge about it…


  • @joekamprad Budgie desktop was an option during installation. So I’m not sure what you mean by not shipped by default?

  • @ashraf
    Aren’t you confused with Reborn OS, it’s a distro that is derived from Antergos. They have Budgie as one of their default choices in DE.

  • @ashraf id you install from Antergos ISO you can not choose budgie as Desktop environment. And configurations for not default choosable DE are not ready or not updated, they are under development and not tested to work already.

  • I’m very confused now. It is most definitely Antergos, but now I’m just wondering if I installed budgie after finishing the installation. I could swear it was during the installation process and one of the desktops listed. Here’s my cat /etc/*-release

    NAME="Antergos Linux"
    PRETTY_NAME="Antergos Linux"
  • It’s hard to say in this case, because Reborn OS uses the Antergos repositories, so it’s ID as Antergos. Also it’s not that long ago that cnchi within Reborn showed the Antergos logo during install.
    But most importantly: Did you find a solution in the mean time?

  • pacman -Qs antergos-budgie-meta

    It is possible to install budgie, if you run cnchi-dev version, as it will enable all hidden DE’s aviable as meta packages… or after initial install over pamac package manager…

    Also i would say that your issue is not 100% related to DE, and more an issue with driver/modules and hardware itself…

    you can give the boot yournal and all specs by running this inside a terminal:

    lspci > log.txt && lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F [email protected] https://ptpb.pw/?u=1

    it will give out a url at the very end with a pastebin of systemspecs and boot journal you can provide here.

  • I apologize for not replying earlier. As long as I didn’t power off/on my laptop, I didn’t face this issue. When I power my laptop off then on, the keyboard/touchpad doesn’t work on login screen. I would have to connect a USB keyboard and mouse, login (still internal keyboard/touchpad wouldn’t work after login), suspend my laptop, then wakeup, that’s how I get my laptop’s internal keyboard and touchpad to work again. After that, as long as I don’t power off my laptop I’m fine (even a reboot is fine).

    I just powered on my laptop (sure enough, no internal keyboard/touchpad working), connected external keyboard and mouse, and wrote this reply before doing the suspend/wakeup juggle. Here are the logs


    I tried switching lighdm greeter from webkit2 to gnome, tried switching from lightdm to gdm. None of that worked.

keyboard75 touchpad55 bootreboot1 Posts 9Views 446
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.