• Recent updates completely broke my system.


    Just updated tonight and got a message saying to restart. Upon restarting I get a black screen with a blinking “_” in the top left corner. I am unable to access a terminal once this happens. I can spam ctrl+alt+f2 while it’s booting and sometimes get to a terminal. Everything had been working perfectly for the last 4 or so months. I tried some gdm and lightdm stopping and started that I found on the internet but nothing changes.

    Please help.

    Ryzen 1700x
    r9 fury
    mesa 18.3

  • @chasem
    That sounds like a graphics driver problem.
    Could you show the output of terminal command

    lspci -vnn
    

    One thing to try is using another linux kernel.

    sudo pacman -S linux-lts linux-lts-headers
    

    and reboot using the LTS kernel (from additional boot menu), not the original.

    Another thing that might help is to use the dkms versions of the graphics drivers (and download also linux headers).

  • Yeah this seems completely related to the latest mesa-git update. A second pc went down after updating mesa-git as well.

    Still a 3rd system managed to make it through the update fine. I guess that’s the main problem running so bleeding edge.

  • @chasem
    Why use mesa-git from AUR instead of the official mesa?

    It is generally a bad idea to replace official packages with AUR packages, as AUR packages are not officially supported.

  • https://wiki.archlinux.org/index.php/ATI

    Graphics Processor: GCN 3 = Driver usable = AMDGPU Or: Catalyst /AMDGPU PRO
    Sources: sapphire-nitro-r9-fury // Xorg#AMD

    amdgpu install and info: AMDGPU

  • As far as i can see no need for mesa-git… and may simple have mesa-git installed is causing the problem after update

  • Yes this was directly caused by the latest updates to mesa git. Specifically libdrm-git-6433.1e3fcc49 and mesa-git-104860.18a6e426f3 as some other users reported elsewhere.

    @joekamprad said in Recent updates completely broke my system.:

    @chasem said in Recent updates completely broke my system.:

    r9 fury

    https://www.phoronix.com/scan.php?page=article&item=amd-r9-fury&num=1

    The Problem is the GPU here…

    That is 3 years old. And no longer the case. There are still some issues but most are solved by newer packages. Performance wise only vega beats it. Stability wise I’ll give a slight nod to hawaii, r9 290/390.

    @manuel said in Recent updates completely broke my system.:

    @chasem
    Why use mesa-git from AUR instead of the official mesa?

    It is generally a bad idea to replace official packages with AUR packages, as AUR packages are not officially supported.

    I understand. But official packages sometimes move to slowly. I wanted the increased compatibility profiles and didn’t want to wait for 18.2 to make it into official packages which just happened a few days ago.

    Also Polaris and Fiji cards have several issues with shader compilation on llvm 6. All those issues go away on llvm 7 which i’ve been able to use for the last year via llvm-svn and still isn’t in official packages unless something just recently changed. And the easiest way for the last year to get llvm 7, now 8, is to use mesa-git which installs it as a dependency.

    Anyway this is solved. Sorry I jumped the gun in asking for help here. Use bleeding edge software get bleeding edge bugs.

  • @chasem may next time telling the story with your question then… ⛓

system146 updates71 broke25 completely7 Posts 10Views 560
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.