• Phishing popup in cnchi followed by crash


    0_1537109514418_6757ad87-ea17-4e24-af96-ffb6561d1e05-image.png
    This phishing site appears when running cnchi.

    Shortly after the installer will crash with this error:
    0_1537109567802_242c4057-7025-4a38-a1c6-f1e60e240788-image.png

  • @clipsey

    oh god, are you by any chance installing using the minimal iso too? coz im currently installing openbox and these popups are starting to show

  • @retrowertz I’m using the large ISO, so i think their DNS entry has been hijacked.

  • I have a workaround for the phishing popup; open /usr/share/cnchi/src/pages/slides.py in a text editor. and set the URI value to something else (like ‘https://google.com’); xcb still crashes, though.

  • im almost done installing. popup do not happen on cnchi window though(i never did that captha thing). popup happen here in midori while browsing, sometimes totally replaces the url with something like an online game thing.

  • my crash seems to have been caused by a residue file system left over from removing fedora, rebooting seems to have fixed that.

    as for preperation, here’s some steps that makes the installer not crash for dumb reasons:

    # uncomment multilib
    sudo nano /etc/pacman.conf 
    
    # update package lists
    sudo pacman -Syy
    
    # install new mirrorlists
    sudo pacman -S antergos-mirrorlist pacman-mirrorlist
    
    # install new version of cnchi, the auto updater doesn't do it for some reason.
    sudo pacman -S cnchi
    
    # change the text on the line containing "URI = '(link)'" to point to google.com
    sudo nano /usr/share/cnchi/src/pages/slides.py
    
    # start the installer
    sudo cnchi
    
  • @clipsey aside from slides.py edit, this is basically what i do )or need to do) when installing antergos.

    from my experience, installing antergos-mirrorlist does not do a thing since this will not overwrite /etc/pacman.d/antergos-mirrorlist, unless you manually extract package and for installing it(the default and only enabled mirror in antergos-mirrorlist does not work for me)

  • ok think im stuck. its taking 16minutes now to download linux-firmware

    2018-09-16 15:25:16 [INFO] slides.py(281) manage_events_from_cb_queue(): Downloading linux-4.18.7.arch1-1-x86_64...
    
  • @retrowertz some packages seems to be on only some mirrors, resulting in long wait times before the actual package gets installed, happened to me with the gnome keyring.

  • This post is deleted!
  • I just installed Antergos again using 18.8 full version and indeed the cnchi installer got corrupted showing I actually won a brand new phone ☺ hehe. Although I did not expirience any problems besides that, the installation went fine. Although I wonder if my system got infected with some malware during installation or something?

  • My workaround worked and i got Antergos installed.

  • @developers?

    looks alarming to me ☠

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • not sure why this is marked solved…

  • Just reopen this!

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • I agree this should be re-opened and there should be an explanation of what is happening. How can we be sure new installs are not compromised at the moment?

  • this must be some kind if “IP-Hijacking” or similar, and yes i am not sure if this can also compromise installations, this should not happen inside install process…

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • BUG reported:
    https://github.com/Antergos/Cnchi/issues/1091

    [updates once a week] = [90% less problems]
    antergos:_rescue
    how to add system logs:
    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
    :handshake: donate antergos

  • @dwitman domain is probably attacked, so i doubt it.

cnchi149 popup2 followed1 phishing1 Posts 28Views 1424
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.