• Win10 guest capturing keyboard does not work

    Hi, I use Antergos with DE Gnome. I have a win10 guest OS installed on Oracle VM. All shortcuts go to the Antergos host no matter if I capture keyboard and mouse.

    I tried to install win10 as a guest OS on VM workstation and there I have the same problem.

    Does someone have a solution to this problem?

    Thanks a lot

  • @nicolas-almy
    Have you installed packages virtualbox-guest-iso and virtualbox-ext-oracle to your antergos host?
    And have you installed Guest additions to the Windows 10 guest?

  • Yes all those things are installed

  • @nicolas-almy
    And is your user on host in group vboxusers?

  • @nicolas-almy said in Win10 guest capturing keyboard does not work:

    All shortcuts go to the Antergos host no matter if I capture keyboard and mouse.

    What exactly do you mean by this?
    Do you mean: if you try to copy something from host to guest via the clipboard, it doesn’t work?

  • Yes, that’s an example what doesn’t work. Win+E doesn’t work, and such shortcuts.

  • @nicolas-almy
    So you need to share the clipboard. It can be shared using both directions (host <-> guest), or only one direction of your choice.

    In the guest VM window, select Devices -> Shared Clipboard and there you can select the direction.
    On the Devices menu there are also other related settings (like Drag and Drop) that you may find useful.

  • And there are other menus like Input -> Keyboard -> Keyboard Settings that may help you configure the right assignments.

  • Ok now copy paste works fine, but Win+E and Win+R and such shortcuts still don’t work.

  • @nicolas-almy
    Was there no option for setting them? Then I’m out of ideas for now…

    Unless it is some Gnome settings; I’m not using Gnome so maybe some Gnome expert could help more.

    It is also possible that those keys are directly used by Gnome. The Win key has a different name on Linux systems, something like “Super” as far as I can remember.

  • Ok thanks for your help so far.

  • So I solved that problem by reinstalled Antergos again with KDE Plasma, KDE has a tool called kwin in which you can specify that a program should ignore global shortcuts.

    Just as information for anyone how has this problem or a similar one.

  • You can do disable shortcuts under Gnome also inside settings.

gnome361 vbox5 Posts 13Views 364
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.