• No WiFi Adapter Found, no access to wired connection


    I’m trying to install Antergos on my mid-2012 MacBook Pro and the live-boot USB is not detecting my wirelesscard. This wouldn’t be a problem except that I do not currently have wired network access. I tried to tether to my iPhone 7 using bluetooth and USB but Bluetooth does not want to enable, and USB isn’t detecting at all.

    Here’s what I’ve got so far:
    Arch Wiki said to use lspci -k to find the adapter, so it gives me

    [[email protected] ~]$ lspci -k
    03:00.0 Network controller: Broadcom Limited BCM4331 802.11a/b/g/n (rev02)
            Subsystem: Apple Inc. AirPort Extreme
            Kernel driver in use: bcma-pci-bridge
            Kernel modules: bcma, wl
    

    So it seems that it has kernel drivers but under System Settings >> Wi-Fi it is saying, “No Wi-Fi Adapter Found”

    As per this post I’ve tried

    sudo modprobe -r tg3
    sudo modprobe broadcom
    sudo modprobe tg3
    

    Unfortunately this produced no change.

    Another forum post lead to to using ip link, which shows shows loopback and:

    4: enp2s0f0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisk mq state DOWN mode DEFAULT group default qlen 1000 link/ether a8:20:66:2b:3e:09 brd ff:ff:ff:ff:ff:ff
    

    I’ve tried

    sudo ip link set enp2s0f0 up
    

    But that produced no change. I suspect that’s my wired network adapter.

    I’m still very much a Linux noob and totally out of ideas at this point, beyond waiting until I can access a wired connection. I’d still like to solve this just for my own satisfaction!

    Thanks for the help!

  • Not solved, but progress!

    I noticed that under lspci -k the wired ethernet connection showed the kernel module as being tg3, so I tried applying the modprobe instructions to the kernel modules listed under the wireless adapter:

    sudo modprobe -r bcma
    sudo modprobe -r wl
    sudo modprobe -r broadcom
    sudo modprobe bcma
    modprobe: ERROR : could not insert 'bcma': Input/output error
    sudo modprobe wl
    sudo modprobe broadcom
    
    

    Now when I enter ip link I see

    ip link
    7: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN mode DEFAULT group default qlen 1000
    link/ether (unit's MAC address) ff:ff:ff:ff:ff:ff
    

    iwconfig produces

    iwconfig
    bash: /usr/bin/iwconfig: Input/output error
    

    In System Settings it’s at least giving me the option to turn WiFi off and on even though it’s described as, “unavailable” and no networks show up.

    From these outputs I’m guessing that the problem is related to this ‘bcma’ kernel module. I’ll keep combing through the docs, but if you have any ideas please send them my way!

  • @gimmetheclacc
    If you didn’t do it already, you could try installing package b43-firmware.
    And show the output of command

    lspci -vnn | grep -A7 Network   # 7 = lines after match
    

    before and after installing that package.

    Please report issues including all details! ;-)
    Show files here: cat "file" | curl -F [email protected] https://ptpb.pw/?u=1
    and show the URL here.

wifi126 connection30 adapter13 wired7 Posts 3Views 83
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.