• Unable to start Seahorse?


    I have two new, freshly installed computers where I am running Antergos and Gnome. I see seahorse is running, using the following: /usr/bin/seahorse --no-window
    But when I try to start Seahorse (Password & Keyring), the GUI, then nothing happens. I am unable to start/show the application, what am I missing? This is the same for both my computers.

    BTJ

  • @bjorntj
    What happens if you start it on a terminal with command:

    seahorse
    

    Does it give any warnings?

  • @manuel

    Not really, it just says:

    (seahorse:18433): Gtk-WARNING **: 11:44:51.380: Theme parsing error: gtk.css:1:8: Expected a valid selector
    
    (seahorse:18433): Gtk-WARNING **: 11:44:51.380: Theme parsing error: gtk.css:12:2: Expected a valid selector
    
  • @bjorntj
    Here it starts OK on Xfce, and doesn’t give any warnings at all.

    Maybe it is a problem with some of its dependencies. You could try reinstalling it:

    sudo pacman -S seahorse
    

    If that doesn’t help, please check that your themes are OK, since it is complaining about them.

  • Already tried reinstalling seahorse… Also tried to start it with default theme (and others), but still the same… :-|

  • @bjorntj
    Ummm… It must be related to some dependency problem. Have you uninstalled something lately?

    One (a bit laborious but easy) thing maybe worth trying is to install Antergos on VirtualBox and see if seahorse runs there without problems. If it does, then find the differences…

  • Nope, as I said, these are two freshly installed computers, installed fresh a couple of days ago…

    I will try to install it in VirtualBox just as a test… :)

    btw, can Gnome extensions play a part here?

  • @bjorntj
    Maybe. Not sure though since I’m not using Gnome.
    But Gnome extensions have reportedly caused many issues before, so uninstalling them (e.g. one by one) may solve the issue.

  • ok, will try Virtualbox and see… And install one and one extension if it works initially… Thx… :)

  • ok, fresh install under VirtualBox and the first thing I do is to try to run seahorse after first boot. Still nothing.
    But I tried something. If I kill the process seahorse --no-window that is running in the background, then I am able to start the application.
    So my question is then, should seahorse be running in the background? And if so, how can I show the application when the process is already running using Gnome? And if not, why is it running?

  • @bjorntj
    On Xfce, seahorse does not run in the background by default, and if I start and stop the seahorse application, after stopping it is not in the background.

    So the issue seems to be related to some Gnome settings or some Gnome extension.
    Do you have any Gnome extensions installed? If not, then some Gnome settings must be involved.

    But maybe someone with more Gnome experience could help out here?

  • On the Virtualbox install, I have not installed any Gnome extensions, but by default some are included…
    But yes, this seems to be Gnome and/or Gnome extension related, hopefully someone have a better understanding about Gnome 3 than I do at the moment. (Been using Openbox for many years but decided to try Gnome…) :)

  • @bjorntj
    By the way, Xfce has been running very well on my Antergos machines for quite a long time… ;)

  • @manuel
    Can’t see any reasons why not… :) Was using XFCE before I switched to Openbox…

  • @bjorntj
    Just out of curiosity, started installing Gnome version to VirtualBox…

  • Gnome Wayland session maybe?
    Try login to gnome X-Org …

  • Thx, but I am actually using both. My laptop is using Wayland and my workstation is using Xorg… :)

  • @bjorntj
    Sorry, cannot install Antergos now, must try again later…

  • I can check in one hour, I do have Gnome and Gnome into VM aviable…

  • Now I got Gnome installed. It starts OK, but the warning is different:

    $ seahorse
    
    (seahorse:1189): Gtk-WARNING **: 16:25:02.290: Locale not supported by C library.
    	Using the fallback 'C' locale.
    seahorse-Message: 16:25:02.421: DNS-SD initialization failed: Daemon not running
    
unable70 seahorse3 Posts 32Views 926
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.