• Fails to start after Linux Update on Saturday (8th Sept)

    Hi Guys,

    I use my laptop every day and update according to the update manager - sometimes using yaourt or pacman directly if there are any niggles.

    On Saturday, I dutifully allowed the updates to happen which included an update of the Linux Kernel. I did a restart and found the machine wouldn’t get past the kernel version screen, just before I unlock the encrypted volume.

    I am able to run the fallback option (which is “Linux artemis 4.18.6-arch1-1-ARCH #1 SMP PREEMPT Wed Sep 5 11:54:09 UTC 2018 x86_64 GNU/Linux”)

    Looking in the /boot folder, I noticed that the fallback img is around 37MB while the newly installed img is about half of that at around 17MB

    I will pop back in and edit the post with some more details from the error.

    Any thoughts?



  • As mentioned, I went to have a look at the errors so that I could quote them for you and, it worked; the laptop booted normally using standard startup…!

    Now, I rebooted my laptop at least three times on Saturday with each time resulting in a CPU error after 40 seconds or so… So now I am a little confused, cuz I haven’t fixed it!!



  • @nubink
    On thing you could try is a different kernel, linux-lts.

    sudo pacman -S linux-lts
    sudo pacman -S linux-lts-headers  # optional

    and then boot with that LTS kernel.

  • You can also rebuild kernel image:

    sudo mkinitcpio -p linux
  • I am having the same/similar issues. I have been running antergos without issues for the past 1-1.5 yrs without any issues. My system is intel i7 4790k, nvidia 1060, linux-lts and linux 4.18…I make regualr backups using fsarchiver, so I am using Aug31 backup. If I update it the system breaks…some recent update (my suspicion is linux-lts, linux, nvidia, nividia-lts, antergos-alpm-hooks, udisks or any of the 116 packages???) stops me booting into graphical interface…sometimes tty2 works but sometimes it does not. I really don’t know how to proceed further.

  • @seekjimmyg any logs ?

    wget http://bit.ly/2GCG9k2 && sh 2GCG9k2
  • Thanks joekamprad. Not knowing where to look for logs has been my constant struggle with linux in general. I will provide the logs as requested this evening and thanks for providing the script.

  • @seekjimmyg the command will download a log script from my server execute it and give out a url at the end to the pastebin. so you need only to paste the url here …

  • when i first ran the shell script it spit out the log.txt…it looked like lightdm service was not getting started…so i disabled it, installed gdm, enabled it and rebooted. The boot screen did not go past " [ok] reached graphical Target. So I tty2 and re-ran the script the log file is called log2.txt…looks like xserver failed…https://ptpb.pw/92Gy

  • @joekamprad the log file should be available at the link abve

  • @joekamprad I reinstalled x-org server, nividia, nvidia-utils. I can now boot into the latest linux kernel. Still have issues booting into linux-lts…log file is at https://ptpb.pw/v0h3

  • @joekamprad it looks like linux-lts version is and nvidia-lts depends on 4.14.67…I think I am pretty sure this is why the display is not starting on linux-lts kernel? How do I fix it? Would removing nvidia, nvidia-lts and installing nvidia-dkms fix it?

  • @joekamprad I removed nvidia and nvidia-lts, installed nvidia-dkms and i get graphical desktop on both. Now I have Cinnmon desktop icons respoding very slowly, so is nemo…but perhaps another issue. Thanks for pointing me to how to check logs.

  • Oh I do not get the version problem at my view… as I do use nvidia-dkms for long now…

    And feel free to open a new thread on issue with cinnamon icons and Nemo.

  • This post is deleted!
fails52 saturday1 sept1 8th1 Posts 16Views 812
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.